cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1791
Views
20
Helpful
8
Replies

2821 with NME-X-23ES-1G-P

benherman77
Level 1
Level 1

I've been messing with an EtherSwitch module and I can't seem to get it to function the way I want.  The router will connect with the ONT and I have connectivity.  I can ping the Vlan on the switch from the router....but no traffic, no ip's being pushed.  Here are the configs, please take a look and explain where I messed up.

 

Router#sh run
Building configuration...


Current configuration : 1601 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool Network
network 192.172.201.0 255.255.255.224
default-router 10.0.0.1 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
domain-name Herman
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.201
encapsulation dot1Q 201
pppoe enable
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
ip address pool Network
duplex auto
speed auto
!
interface GigabitEthernet1/0
ip address 10.0.0.1 255.255.255.0
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname xxxxx
ppp chap password 0 xxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.0.50.0 255.255.255.0 10.0.0.2
!
!
ip http server
no ip http secure-server
ip nat inside source list 10 interface Dialer1 overload
!
control-plane
!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Router#

 

Switch#sh run
Building configuration...

Current configuration : 2758 bytes
!
! Last configuration change at 19:03:07 UTC Thu Apr 20 1905
! NVRAM config last updated at 18:48:54 UTC Thu Apr 20 1905
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision NME-X-23ES-1G-P
ip subnet-zero
ip routing
!

no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet1/0/2
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/3
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/4
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/5
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/6
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/7
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/8
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/9
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/10
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/11
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/12
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/13
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/14
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/15
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/16
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/17
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/18
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/19
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/20
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/21
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/22
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/23
switchport access vlan 50
switchport mode access
!
interface FastEthernet1/0/24
switchport access vlan 50
switchport mode access
!
interface GigabitEthernet1/0/1
switchport access vlan 50
switchport mode access
!
interface GigabitEthernet1/0/2
no switchport
ip address 10.0.0.2 255.255.255.0
!
interface Vlan1
no ip address
!
interface Vlan50
ip address 10.0.50.1 255.255.255.0
ip helper-address 192.172.201.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
!
end

Switch#

8 Replies 8

Philip D'Ath
VIP Alumni
VIP Alumni

Normally you would poing the IP helpher to an actual DHCP server, not "ip helper-address 192.172.201.0".

 

Do you have a DHCP serving up IPs for 10.0.50.0/24 ?  If so, point the helper at that.  Otherwise you can configure the router to do DHCP for this VLAN.

forgive me, my knowledge level is very entry level....I did as you suggested and made my DHCP pool 10.0.50.0/24 and I also put the Vlan50 ip helper-address as 10.0.50.0 ....still no luck. I think I have something wrong with my DHCP being pushed from the router to the switch module...just not sure

ip dhcp pool Network
network 10.0.50.0 255.255.255.0
default-router 10.0.0.1 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
domain-name Herman

interface Vlan50
ip address 10.0.50.1 255.255.255.0
ip helper-address 10.0.50.0

Get rid of the ip helper-address 10.0.50.0" line on vlan50 and it should work.

No luck

Try giving it a reboot with the new config in place.

I did a complete reboot...no joy. Sh Ip dhcp bindings is empty..and my
laptop goes down.

Perhaps vlan 50 is missing from the switch module. At the command line - but not in config mode - try:
vlan database
vlan 50
exit

Then give it another reboot.

still nothing, gonna WR Erase and start over...also I apologize for posting this in the wrong group...will pay more attention to that next time. I think that instead of making my Router G0/1 my LAN port I will put all those settings on G1/0 since that is facing the switch module... thanks for all the help and ideas Philip!!