Showing results for 
Search instead for 
Did you mean: 

Cisco AnyConnect Constantly Reconnecting on Macbook Pro

Level 1
Level 1

Hi Folks,


In the past month my VPN AnyConnect is constantly reconnecting. From every 3 minutes to every 15 minutes at times. This is a major blocker for attending meetings and workflow interruptions. 


I've tried various changes from IPv6 disabling to MTU adjustments but none of these tweaks are correcting the problem.


Macbook Pro 15-inch, 2018

macOS Mojave 10.14.5

Cisco AnyConnect Secure Mobility Client Version 4.7.01076

AT&T Gigabit 

Router Model5268AC
Hardware Version260-2173300
Software Version11.1.0.531418-att


I did do a test and spent 1.5 hours at Starbucks connected to the VPN with no issues. What is it with AT&T and Cisco combination that is causing the constant reconnects?


Thanks for any help.  


11:23:53 AM Reconnecting to ******.com...
11:23:55 AM Establishing VPN - Examining system...
11:23:55 AM Establishing VPN - Activating VPN adapter...
11:23:55 AM Establishing VPN - Configuring system...
11:23:58 AM Establishing VPN...
11:23:58 AM Connected to ******.com...
11:25:53 AM Reconnecting to ******.com...
11:25:56 AM Establishing VPN - Examining system...
11:25:56 AM Establishing VPN - Activating VPN adapter...
11:25:56 AM Establishing VPN - Configuring system...
11:25:58 AM Establishing VPN...
11:25:58 AM Connected to ******.com...
11:27:01 AM Reconnecting to ******.com...
11:27:03 AM Establishing VPN - Examining system...
11:27:03 AM Establishing VPN - Activating VPN adapter...
11:27:03 AM Establishing VPN - Configuring system...
11:27:06 AM Establishing VPN...
11:27:06 AM Connected to ******.com...
11:30:37 AM Reconnecting to ******.com...
11:30:39 AM Establishing VPN - Examining system...
11:30:39 AM Establishing VPN - Activating VPN adapter...
11:30:39 AM Establishing VPN - Configuring system...
11:30:52 AM Establishing VPN...
11:30:52 AM Connected to ******.com...
11:32:37 AM Reconnecting to ******.com...
11:32:40 AM Establishing VPN - Examining system...
11:32:40 AM Establishing VPN - Activating VPN adapter...
11:32:40 AM Establishing VPN - Configuring system...
11:32:42 AM Establishing VPN...
11:32:42 AM Connected to ******.com...

34 Replies 34

Rahul Govindan
VIP Alumni
VIP Alumni

@brandonleetran I have the exact same ATT setup.


Manufacturer Pace Plc
Model 5268AC
Serial Number xxxxx
Hardware Version 260-2173300
Software Version


I have not seen this issue when using AnyConnect VPN from my Mac Air (High Sierra). Do you see any packet loss for traffic going to your gateway? Try running a ping to the gateway before and during connection and see if there any difference. 

Wow thank you all for providing helpful tips. Much much appreciated. 

@Rahul Govindan 

I'm on a mac and I used `Network Utility` to run a ping on my router IP. I'm actually not sure what you mean by gateway IP. Any clarification on that would be awesome.  So I ran a ping on my router IP and I got regular 3-10 ms responses. When I connected to VPN I get timeouts `Request timeout for icmp_seq 0`

Cisco Employee
Cisco Employee

Hi Brandon,

I think you may be hitting this issue.


Apple introduced hardware changes in their 2018 models (2018 MacBook Pro, 2018 MacBook Air, and 2018 Mac mini in which also include their new T2 Security Chip).  It has been determined that due to Apple’s changes, features/functions specific to AWDL (ie: AirDrop, Apple Watch, AirPlay, BlueTooth, etc), in which all use Apple’s dedicated ‘awdl0 interface’, are handled differently by the hardware.  Please see  the fix will be available end of June or early July.  Please test the workarounds in the bug to be sure this is the issue you are having.  Without logs it is difficlut to say.



Steve S.

@stsargen Awesome thank you for that tip. I'm holding out hope that it will get better. I disabled air drop as per workaround instructions. And now I am running video conference on 2 computers and screen sharing and It does seem to be working without any reconnecting. Maybe it's a great workaround!

Temporarily turn off (disable) AirDrop:

1. Open a Finder window
2. Click on AirDrop from the left menu
3. At the bottom of the window, change 'Allow me to be discovered by' to No One

I have the same issue and disabling air drop did not resolve it.  I have to disable bluetooth entirely.

same here...

I had the exact same problem.  Cisco IT support was pretty worthless, and I found this thread, turned off BlueTooth and the VPN has stopped bouncing!   I need BlueTooth to work though!   

Most likely its mtu value. Try the following:

1. Disable DTLS and test.
2. If the problem presists while dtls is off reduce the mtu value to 1250
and see if works.



The version with the fix for this is now posted on  The version number is 4.7.04056.  (Corrected version number)


Steve S.

Release notes don't mention this issue... ? 

As mentioned previously in this thread the bug ID is CSCvp04196.  This is listed in the resolved caveats section of the release notes.


CSCvp04196 -- ENH: Optimize tunnel security reinforcement on macOS upon virtual adapter detection

Hi Steve, 


I'm running v 4.6.03049 and it's still only staying up when I turn Bluetooth off.  

Hi Scott,


The bug only lists as being fixed in the latest 4.7.04056 release available on CCO,  Please upgrade and see how you make out.



Steve S.


This fixed the issue till 10.14.6 came out. Now it’s back again.