07-18-2021 12:02 AM
Dear All
I created one lap using DMVPN between R11, R31 and R41
I used EIGRP between 3 routers, the tunnel interface is up and R11 can learn R31 and R41 routes
I want R31 to learn R41's route through R11, but that doesn't happen
show ip route on both routers shows only R11 route
I tried to disable split horizon on R11's Gig 0/0 but nothing change
R11#show running-config | section interface
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp map multicast dynamic
ip nhrp network-id 100
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 100
R31#show running-config | section interface
interface Tunnel100
bandwidth 4000
ip address 192.168.100.31 255.255.255.0
ip mtu 1400
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11 nbma 172.16.11.1 multicast
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/1
tunnel destination 172.16.11.1
tunnel key 100
R41#show running-config | section interface
interface Tunnel100
bandwidth 4000
ip address 192.168.100.41 255.255.255.0
ip mtu 1400
ip nhrp map 192.168.100.11 172.16.11.1
ip nhrp map multicast 172.16.11.1
ip nhrp network-id 100
ip nhrp nhs 192.168.100.11
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/2
tunnel destination 172.16.11.1
tunnel key 100
R11#show dmvpn | begin Peers:2,
Type:Hub, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 172.16.31.1 192.168.100.31 UP 05:30:06 D
1 172.16.41.1 192.168.100.41 UP 05:21:29 D
R11#show ip route | begin Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, GigabitEthernet0/1
L 10.1.1.1/32 is directly connected, GigabitEthernet0/1
D 10.2.2.0/24 [90/26885120] via 192.168.100.31, 00:41:05, Tunnel100
D 10.3.3.0/24 [90/26885120] via 192.168.100.41, 00:48:02, Tunnel100
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.11.0/24 is directly connected, GigabitEthernet0/0
L 172.16.11.1/32 is directly connected, GigabitEthernet0/0
O 172.16.31.0/24 [110/2] via 172.16.11.2, 05:53:03, GigabitEthernet0/0
O 172.16.41.0/24 [110/2] via 172.16.11.2, 05:53:03, GigabitEthernet0/0
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
L 192.168.100.11/32 is directly connected, Tunnel100
R41#show ip route | begin Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.1.0/24 [90/26885120] via 192.168.100.11, 00:42:51, Tunnel100
C 10.3.3.0/24 is directly connected, GigabitEthernet0/0
L 10.3.3.3/32 is directly connected, GigabitEthernet0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O 172.16.11.0/24 [110/2] via 172.16.41.2, 06:02:55, GigabitEthernet0/2
O 172.16.31.0/24 [110/2] via 172.16.41.2, 06:02:55, GigabitEthernet0/2
C 172.16.41.0/24 is directly connected, GigabitEthernet0/2
L 172.16.41.1/32 is directly connected, GigabitEthernet0/2
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
L 192.168.100.41/32 is directly connected, Tunnel100
R31# show ip route | begin Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.1.0/24 [90/26885120] via 192.168.100.11, 00:43:09, Tunnel100
C 10.2.2.0/24 is directly connected, GigabitEthernet0/0
L 10.2.2.2/32 is directly connected, GigabitEthernet0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O 172.16.11.0/24 [110/2] via 172.16.31.2, 05:28:04, GigabitEthernet0/1
C 172.16.31.0/24 is directly connected, GigabitEthernet0/1
L 172.16.31.1/32 is directly connected, GigabitEthernet0/1
O 172.16.41.0/24 [110/2] via 172.16.31.2, 05:48:21, GigabitEthernet0/1
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
L 192.168.100.31/32 is directly connected, Tunnel100
Solved! Go to Solution.
07-18-2021 04:53 AM
You still have split horizon disabled on the Gi0/0 interface and not disabled on the Tunnel interface.
Your configuration on R11
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp map multicast dynamic
ip nhrp network-id 100
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 100
!
interface GigabitEthernet0/0
ip address 172.16.11.1 255.255.255.0
ip access-group TEST out
no ip split-horizon eigrp 100
duplex auto
speed auto
media-type rj45
Do this:-
interface tunnel 100
no ip split-horizon eigrp 100
07-18-2021 07:10 AM - edited 07-18-2021 07:15 AM
You are using named EIGRP, so you will need to disable split horizon under the eigrp configuration instead of under the tunnel interface.
router eigrp NHRP
!
address-family ipv4 unicast autonomous-system 100
!
af-interface Tunnel100
no split-horizon
07-18-2021 12:24 AM - edited 07-18-2021 12:26 AM
Hi @ShamsDim
You need to disable split horizon on the Hub's Tunnel interface (Tu100) not Gi0/0
interface tunnel 100
no ip split-horizon eigrp X
07-18-2021 01:01 AM
I did it now
but still I can't see the routes
R11#show running-config | section interface
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 100
ip nhrp map multicast dynamic
ip nhrp network-id 100
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 100
R31#show ip route | begin Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.1.0/24 [90/26885120] via 192.168.100.11, 01:43:27, Tunnel100
C 10.2.2.0/24 is directly connected, GigabitEthernet0/0
L 10.2.2.2/32 is directly connected, GigabitEthernet0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O 172.16.11.0/24 [110/2] via 172.16.31.2, 06:28:22, GigabitEthernet0/1
C 172.16.31.0/24 is directly connected, GigabitEthernet0/1
L 172.16.31.1/32 is directly connected, GigabitEthernet0/1
O 172.16.41.0/24 [110/2] via 172.16.31.2, 06:48:39, GigabitEthernet0/1
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Tunnel100
L 192.168.100.31/32 is directly connected, Tunnel100
07-18-2021 03:13 AM
Please provide the configuration of the routers.
07-18-2021 04:27 AM
07-18-2021 04:53 AM
You still have split horizon disabled on the Gi0/0 interface and not disabled on the Tunnel interface.
Your configuration on R11
interface Tunnel100
bandwidth 4000
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp map multicast dynamic
ip nhrp network-id 100
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 100
!
interface GigabitEthernet0/0
ip address 172.16.11.1 255.255.255.0
ip access-group TEST out
no ip split-horizon eigrp 100
duplex auto
speed auto
media-type rj45
Do this:-
interface tunnel 100
no ip split-horizon eigrp 100
07-18-2021 05:25 AM
07-18-2021 07:10 AM - edited 07-18-2021 07:15 AM
You are using named EIGRP, so you will need to disable split horizon under the eigrp configuration instead of under the tunnel interface.
router eigrp NHRP
!
address-family ipv4 unicast autonomous-system 100
!
af-interface Tunnel100
no split-horizon
07-18-2021 12:45 PM
it's working now
really appreciate your support
thank you so much
07-18-2021 04:23 AM - edited 07-18-2021 04:29 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide