cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1995
Views
0
Helpful
20
Replies
Highlighted

Cisco WLC 2504 LAG Problem - Controller is shutting down when all four ports are connected

Hi all,

I'm struggeling on a very strange phenomen.

One customer of mine is using a Cisco WLC 2504 controller (AirOS Version 8.2.100.0) connected to a HP switch (I don't know the type of model).

LAG is configured correctly as per configuration guide but it is only working as long as only two out of the four ports are connected.

As soon as port 3 and 4 are plugged in the WLC is not reacting anymore and reboots. There is nothing visible in the show msglog output or traplog output as well as there is no crashinfo available so it seems like a silent crash. However also when having a console cable connected to the WLC nothing is visible.

We have already replaced the WLC but without success.

Any ideas what could cause this?

Regards,

Christian

20 REPLIES 20
Highlighted
Hall of Fame Master

Christian,

I would really look at the switch configuration.  I have a 2504 with LAG and used various code versions without any issue.  The switch however is a Cisco switch.  It is interesting that you can configure LAG and connect port 1 & 2, but when you connect port 3 or 4, the controller reboots.  What happens if you try to connect the 2504 to another switch just for testing.

-Scott 

*** Please rate helpful posts ***

-Scott
*** Please rate helpful posts ***
Highlighted

I'm getting a 2504 WLC today in MY office as well as some HP Switches. I have never faced such an issue before and I've many Setups that are working really good without any issues.

I will try to re-create the issue by today and will post MY results later.

Highlighted

Keep us posted.

-Scott

*** Please rate helpful posts ***

-Scott
*** Please rate helpful posts ***
Highlighted
Hall of Fame Community Legend

As soon as port 3 and 4 are plugged in the WLC is not reacting anymore and reboots.

Sounds like a STP loop-forced crash.  On the controller, post the complete output to the command "sh core summary".

Highlighted

Hi,

No crashinfo file is available at all. Coredump is enabled but nothing is transferred during the time the Controller faces the issue.

Highlighted

Hi there,

 

were you able to resolve your issue, I'm also experiencing same but can't figure out what can be reason. 

Highlighted

If anyone could offer some insight into this it would be greatly appreciated. I have a similar issue. When I plug into port 3 or 4 of the 2504 the controller it shuts down. When I unplug both, the power comes back on and the controller boots up. I'm running code 8.2.166 and the FUS is 2.0. The port channels are correct on my 2960-L switch, and still the same behavior. No misconfigurations on the layer 2 switch side. Like others, I have done this many times and the controller is new.

Highlighted

Any update on this issue?
A customer reported the same problem (2504 shuts down when he connects ports 3&4) but I've run out of 2504 to test this in my lab.


Have anyone test it by first desibling the PoE on the switch ports and then connecting the ports3&4?
Or force the speed and duplex config at both ends instead of leaving it as "auto"?

 

Cheers,
Vasco
Highlighted

 I have the same issue with 8.2.166 version of code. I did try turning POE off on the ports but the controller still crashes when plugging into the POE ports (3 & 4)

Highlighted

CT2504 8.2.166 with FUS 1.9
C2960L Gi0/1 -4 port-channel mode on.

What FUS version do you use?
Highlighted

previous post is short.
In my lab , LAG works fine.
2504 8.2.166 FUS 1.9 and C2960L Gi0/1 -4 channel mode on

and 8.2 116 is deferred , pls use 8.2.170.
Highlighted

Are you guys trying making the LAG with stacked switches or does it happen when connecting to just one switch?

It happened again with a 4port lag to a 3 switch stack. 1 port connected to switch 1; 1 port connected on switch 2 and 2 ports connected on switch 3.


But, when we got all the 2500 on a single switch, all four ports were running whithout any problem.

Cheers,
Vasco
Highlighted

I have the same issue.  I can LAG 1-3 fine but when adding port 4 to the channel, the WLC drops and reboots.  Cannot believe there is no solution for this behavior.

 

ANAKIN#sho int status | i WLC
Gi2/45 WLC LAG connected trunk a-full a-1000 10/100/1000-TX
Gi2/46 WLC LAG connected trunk a-full a-1000 10/100/1000-TX
Gi3/45 WLC LAG notconnect 1 auto auto 10/100/1000-TX
Gi3/46 WLC LAG connected trunk a-full a-1000 10/100/1000-TX
Po50 DOWNLINK to WLC connected trunk a-full a-1000
ANAKIN#sho ehterc 50 sum
^
% Invalid input detected at '^' marker.

ANAKIN#sho etherc 50 sum
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
50 Po50(SU) - Gi2/45(P) Gi2/46(P) Gi3/45(D)  Gi3/46(P)

ANAKIN#sho run int po50
Building configuration...

Current configuration : 223 bytes
!
interface Port-channel50
description DOWNLINK to WLC
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1000
switchport trunk allowed vlan 7,10,40,50,90,100,1000
switchport mode trunk
end

ANAKIN#sho run int g2/45
Building configuration...

Current configuration : 234 bytes
!
interface GigabitEthernet2/45
description WLC LAG
switchport trunk encapsulation dot1q
switchport trunk native vlan 1000
switchport trunk allowed vlan 7,10,40,50,90,100,1000
switchport mode trunk
channel-group 50 mode on
end

 


(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 8.5.135.0
Bootloader Version............................... 1.0.20
Field Recovery Image Version..................... 7.6.101.1
Firmware Version................................. PIC 16.0

Highlighted

Just tested moving a working LAG connection (ports 1-3) from port 3 on the controller to port 4 and it comes up fine.  This indicates to me that there is an issue with the controller when adding the 4th LAG connection with 2 connections to each blade. Moved all 4 connections to the same blade and all 4 come up. It appears that someone decided that the 2504 should not have full redundancy in the LAG for some odd reason.  Have yet to try a 3 and 1 configuration to see if it will work but I have little hope.

Content for Community-Ad