Showing results for 
Search instead for 
Did you mean: 

Problem enabling flexconnect on a WLC

I'm having some trouble enabling flexconnect on a WLAN on my WLC5508

Every time I try to create a Flexconnect WLAN I get an error that the WLC failed to create it

I have 2 other WLANS operating fine but can't seem to be able to get the flexconnect configuration to work

My WLC configuration is below:

software version is 7.3

Management interface tagged with VLAN 99 on port 1 connected to a trunk interface on 4500 switch

Data interface for local users not tagged on port 1

Other interface for second WLAN tagged with VLAN 300 on port 1

1 WLAN created with RADIUS authentication 802.1X PEAP operational

1 WLAN with WPA PSK operational

15 APs registered and operational on both WLANs

2 SFPs plugged into WLC ports 1 and 2 but no interfaces allocated to port 2 at the moment

Please help!!!

Everyone's tags (3)
VIP Mentor

Problem enabling flexconnect on a WLC

What are the steps you are doing to create a FlexConnect WLAN

Check wether you have done this

1. You should havee a flexconnect mode AP in your network

2. That AP should connect via a trunk link back to your switch port

3. Under "FlexConnect" tab of that AP configuration you need to map required vlans where native vlan should be the AP managment in this trunk (AP connected Switch port)

4. Under WLAN advanced settings, you have to enable "Local Switching" if you want to do local switching. Leave it untick if you want to do central switching.

This is some of my notes when I did this on a WLC (feature was called H-REAP in that time & later modified to FlexConnect). This should help you as well




Problem enabling flexconnect on a WLC

Thanks Rasika,

I have flexconnect APs attached to the WLC though no VLAN configuration yet

In the Cisco guide the VLAN configuration comes after you have a working Flexconnect WLAN and the Flexconnect WLAN can be added with or without trunking on the AP. I can't seem to get the WLC to add a Flexconnect WLAN at all.

Hall of Fame Master

Re: Problem enabling flexconnect on a WLC

It is best to tag all vlan's on the WLC for one. Also if you have more than one port connected to the switch and you have LAG enabled, then make sure your etherchannel is up or else you need to remove the other port.

Now when you go to your WLAN advanced tab, at you saying you can't enable FlexConnect local switching? That how you enable FlexConnect on the WLC. To enable FlexConnect on the AP, you need to have the AP join and change the mode from local to FlexConnect.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***

Re: Problem enabling flexconnect on a WLC

Hi Scott, thanks, the LAG / Etherchannel issue looks promising, I'll take a look at the config in a couple of days and see if this makes a difference.

I have several APs configured as Flexconnect and joined and have provisioned a flexconnect group. Whenever I go to the advanced tab of the WLAN window, select "Flexconnect Local Switching" and hit "Apply" I get an error stating that the WLC was unable to enable the flexconnect

VIP Mentor

Re: Problem enabling flexconnect on a WLC

If you are getting an error msg on GUI try this via CLI & see wehter you get an error message in there as well. Here are the CLI to do this on your WLAN

config wlan disable

config wlan flexconnect local-switching enable

config wlan enable



Re: Problem enabling flexconnect on a WLC


the second problem was that the new firmware version 8.5.135 doesnt' accept apex inside the WLC Profile name.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards