cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2006
Views
0
Helpful
2
Replies

1142 Access Point - DHCP trouble

DeeBeeArgh
Level 1
Level 1

Hi there,

I am setting up an autonomous 1142 Access Point. The intended goal is to get it accessible though 2 SSIDs:

Private: VLAN3 (our internal data VLAN)

Guest: VLAN98 (our DMZ/Segregated VLAN)

At present, our VLAN3/internal users get DHCP addresses from x2 Windows DHCP servers. Eventually, the DMZ VLAN connections will get their IP addresses from a switch in our DMZ VLAN.

At the moment, I am able to authenticate with the Access Point through the VLAN 3 SSID but never get an IP address. I have posted the switch port config below as well as the Access Point config. I'm a newbie on these devices so any help would be greatly appreciated:

**SWITCH PORT CONFIG**

interface FastEthernet0/10

description IT Office Wireless Access Point

switchport trunk native vlan 3

switchport trunk allowed vlan 3,98

switchport mode trunk

speed 100

duplex full

spanning-tree portfast

spanning-tree bpduguard enable

**AP Config**

Attached to the post as quite wordy

1 Accepted Solution

Accepted Solutions

pcroak
Cisco Employee
Cisco Employee

Hi Danny,

You have a native vlan mismatch between the AP and the switch. The switchport has vlan 3 defined as the native, but it is not defined as native on your AP.

You will simply want to add the keyword native at the end of the following line under your .3 subinterfaces:

encapsulation dot1Q 3 native

On another note, to take full advantage of the 1140 series AP with 802.11n connections, you will need to use WPA2 with AES encryption:

encryption vlan x mode ciphers aes-ccm tkip

This will allow use of both WPAv1/TKIP and WPAv2/AES

-Patrick Croak

Wireless TAC

View solution in original post

2 Replies 2

pcroak
Cisco Employee
Cisco Employee

Hi Danny,

You have a native vlan mismatch between the AP and the switch. The switchport has vlan 3 defined as the native, but it is not defined as native on your AP.

You will simply want to add the keyword native at the end of the following line under your .3 subinterfaces:

encapsulation dot1Q 3 native

On another note, to take full advantage of the 1140 series AP with 802.11n connections, you will need to use WPA2 with AES encryption:

encryption vlan x mode ciphers aes-ccm tkip

This will allow use of both WPAv1/TKIP and WPAv2/AES

-Patrick Croak

Wireless TAC

Genius! Have now connected successfully on VLAN3 - now to Windows Proxy fun

Many thanks Patrick

Review Cisco Networking products for a $25 gift card