cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5974
Views
5
Helpful
4
Replies
irakli_n
Beginner

2504 - unable to get DHCP address for wireless clients from external DHCP server

Setup/background:

2504 WLC: 3 interfaces connected, 2 in use, three 2700 AP.

 

Interface 1 on WLC is management and as well used for WLAN P700. Here is the switch port config connecting to port 1

 

interface GigabitEthernet1/0/9
switchport access vlan 700
switchport mode access
udld port
spanning-tree portfast
spanning-tree bpduguard enable
end
!

 

And here is port config on WLC

P700.jpg

 

Interface 3 on WLC is used for WLAN P70. Here is switch port config connecting to port 3:

 

interface GigabitEthernet1/0/34
description Cisco 2504 TR
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 70,700
udld port
spanning-tree portfast
spanning-tree bpduguard enable
end

P70.jpg

 

 

 

Problem description.

 

WLAN clients in VLAN 70 can't get IP address from the external DHCP address at 192.168.1.1

Wired client in VLAN 70 can get IP from DHCP server. Wireless clients with static IP also work fine. It is the problem only wireless clients with DHCP.

 

At the same time wireless clients on VLAN 700 which is used/enabled on port1 and co-exists with the management port, are fine - they can receive DHCP IP addresses from the external DHCP server in this VLAN.

 

So problem is only on my second WLAN and with wireless clients.

 

Any idea what could be wrong?

 

P.S. I tried to disable DHCP proxy globally. Same results - DHCP for wireless clients for WLAN P700 on port1 works, DHCP for wireless clients for WLAN P70 on port3 - does not.


1 ACCEPTED SOLUTION

Accepted Solutions

Pieterh,

 

Thanks for reply. After several trial and errors here is the config what made it work.

 

- DHCP proxy is disabled globally

- I added 192.168.1.1 in the WLAN config, Advanced section, as DHCP server

- I added IP helper for interface VLAN70.

 

After this both VLANs/WLANs - 70 and 700 had DHCP working for wireless clients.

View solution in original post

4 REPLIES 4
pieterh
VIP Collaborator

dhcp1.PNG

You configured the WLC as a DHCP-proxy, but do not tell what DHCP server to send it to.

try entering 192.168.1.1 here and test.

 

maybe this document helps DHCP with the WLC

Pieterh,

 

Thanks for reply. After several trial and errors here is the config what made it work.

 

- DHCP proxy is disabled globally

- I added 192.168.1.1 in the WLAN config, Advanced section, as DHCP server

- I added IP helper for interface VLAN70.

 

After this both VLANs/WLANs - 70 and 700 had DHCP working for wireless clients.

pieterh
VIP Collaborator

thank you for marking my reply helpful

and good to hear you found a configuration that works for you.

 

in dhcp-proxy mode the controller forwards the DHCP request using it's management ip adress wich is in vlan700, so I think you need an ip-helper configured on vlan700 (not 70 )and forward it to 192.168.1.1

 

alternatively you can also disable dhcp-proxy on the controller, then the DHCP-packets are just "dropped" on vlan70 and 192.168.1.1 can directly pick up the DHCP-request on this vlan.
(I assume 192.168.1.1 is connected to vlan70, because it works for wired clients )

I had the same issue and followed directions from this Post. Just to mention that on an IOX-XE Cat9k I had to configure :

ip dhcp use vrf remote

 

additionally to other stuff mentioned here!

 

Create
Recognize Your Peers
Content for Community-Ad