Showing results for 
Search instead for 
Did you mean: 

AIR-LAP1242AG-K9 could not join a 2106 WLC: i ma getting ready for a deployment, how can i resolve this?


I setup a mini wireless LAN network lab with a not for resale 2106 wireless lan controller and a sales  air-lap1242ag access point. I do not have a DHCP and DNS in my lab environment. I have configured the WLC with the basic configuration using the CLI wizard, i also configured the WLC as a DHCP server for clients that will be connecting to the APs associated to the controller.

I powered up the AP and connect the ethernet port directly to the controller, the controller issued an IP address to the AP, the AP downloaded a new operating system from the controller but failed to join the controller.

I check both debug message on the controller console and the trap messages on the controller's GUI  and it say the AP could not download a configuration from the controller and it is beacuse of invalid license. Below is the trap message:

Configuration Phase Statistics

Requests Received
Responses Sent
Unsuccessful Request Processed
Reason For Last Unsuccessful Attempt
Last Successful Attempt Time
Last Unsuccessful Attempt Time
Last Error Summary
Last AP Message Decryption Failure
Last AP Connection Failure
Last Error Occurred
Last Error Occurred Reason
Last Join Error Timestamp


Also, I tried to log into the GUI of the AP using the both the username and password  ''Cisco'' but I cannot get into the device. I can only get in through the CLI. In the CLI, almost all the commands I enter gives an error the it is disabled. I don't know what to do any more, I want to know if the access point is faulty or i am not doing the right thing.

PLEASE HELP!!!!!!!!!!!!!!!!!!!

Leo Laohoo
VIP Community Legend

What is the firmware your WLC is running?

IF (and only if) the AP can ping the Management IP address of the WLC then console into the AP and enter the command "lwapp ap controller ip address ".

Thank you for the quick response.

The controller is running firmware version:

Software Version       

Emergency Image Version

The AP can ping the Management IP address of the controller successfully via console. I have also entered in the AP the WLC's Management IP address information and it is still the same. Below is the message I'm getting on the console of the AP it self:

*Jul  9 13:06:09.803: %CAPWAP-3-ERRORLOG: Go join a capwap controller

*Jul  9 13:06:10.000: %CAPWAP-5-DTLSREQSEND: DTLS connection request sent peer_ip: peer_port: 5246

*Jul  9 13:06:10.001: %CAPWAP-5-CHANGED: CAPWAP changed state to

*Jul  9 13:06:11.636: %CAPWAP-5-DTLSREQSUCC: DTLS connection created sucessfully

peer_ip: peer_port: 5246

*Jul  9 13:06:11.638: %CAPWAP-5-SENDJOIN: sending Join Request to

*Jul  9 13:06:11.638: %CAPWAP-5-CHANGED: CAPWAP changed state to JOIN

*Jul  9 13:06:11.724: %CAPWAP-5-CHANGED: CAPWAP changed state to CFG

*Jul  9 13:06:11.726: %DTLS-5-ALERT: Received WARNING : Close notify alert from

*Jul  9 13:06:11.727: %DTLS-5-PEER_DISCONNECT: Peer has closed conne


*Jul  9 13:06:11.727: %DTLS-5-SEND_ALERT: Send WARNING : Close notify Alert to 1

*Jul  9 13:06:11.772: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY

*Jul  9 13:06:11.772: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY

I will also like to know if AIR-LAP1242AG is compatible with WLC 2106 controller.

Any help will be greatly appreciated, i really need to resolve this issue in my LAB now so that I don't go to my customer site to fumble.

thanks in advance.


Please issue the below command and see if the AP join the wlc..

get the AP console access and issue the below command Only if you are able to ping the WLC management ip address..

ap# test capwap controller ip

ex , if ur WLC mgmt ip is

then the command will be

ap# test capwap controller ip

Lemme know if this helps!!



Surendra BG


I have finally rectify the issue. The problem was the country code sellected during the setup of the controller. I copied one of the error message from the controller's console and look it up on cisco site with error message decoder and it points to the country code.

I only have to change the country code on the controller from US (-A) to UK (-E) and the AP joined the controller.

The problem I am facing presently is that the signal strenght. the signal does not go further that 25ft. I walked 28ft away from the AP position and I was disconnected, i cannot even see the AP 28ft to 30ft away from the AP location.

what can i do to extend the signal without buying an external antenna or antenna extender.

Thank you Sure if I may address you that way.

Content for Community-Ad