cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
495
Views
5
Helpful
6
Replies
Highlighted
Beginner

Aironet Client MAC Address Changes

My company did an upgrade to their WiFi access points and I ended up getting one of the Aironet 2700i APs. I was able to install the autonomous firmware and got it working. I have a Linux system performing firewall and DHCP services. When a device connects to the Aironet, the DHCP server reports that a different MAC address has requested an IP than what is on the device. I looked on the Aironet client list and the correct MAC address is there. Even more curious is that I get a different MAC address for the client if I connect to 2.4GHz or 5GHz. Since some of the devices are set with a static IP based on their MAC address, the DHCP server is giving out an IP from the pool instead of the static one.

 

Why is the Aironet forwarding a different MAC address and how can I get it to forward the devices correct one?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

I have not seen that before unless the device itself has “randomized MAC address” enabled. I know that this is default on some devices I have tested with.
-Scott
*** Please rate helpful posts ***

View solution in original post

6 REPLIES 6
Highlighted
Hall of Fame Master

I have not seen that before unless the device itself has “randomized MAC address” enabled. I know that this is default on some devices I have tested with.
-Scott
*** Please rate helpful posts ***

View solution in original post

Highlighted

Do you know off hand where that setting is?



 

Highlighted

Oh, sorry. No, the device isn't randomizing the MAC (non-Cisco APs don't have this issue).

Highlighted
Beginner

Nevermind, the problem is on the device!
Highlighted

What did you find?
-Scott
*** Please rate helpful posts ***
Highlighted

Sorry if I wasn't clear. The Android device was randomizing the MAC address by default. The option was buried and on by default. Regular home routers don't allow for that, so I hadn't run into it before.