cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8954
Views
5
Helpful
17
Replies

Apple MAC Bonjour and Cisco Aironet 1142

milkboy33
Level 1
Level 1

Hi All,

   Hope all is well.

   We have a strange issue with our two Aironet 1142s and how it interacts with our Apple laptops. When we try printing to a printer in one room connected to (let's call it Aironet 2) we can't. We attempt to browse using Bonjour (Apple's protocol) to the printer and can't. HOWEVER.. we can print and browse fine when we're using Aironet 1.

   Another strange thing is when we're on Aironet 2 we can ping to the printers just fine, just can't browse to is using Bonjour nor print of course.

Please help! Any inputs appreciated.

-Tom

17 Replies 17

Scott Fella
Hall of Fame
Hall of Fame

I'm guessing that the AP's are on the same subnet and on the same subnet as the printers. Is the configuration identical between the two AP's except of course for the host name and ip address? How about the switchport configuration?

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***

Yes they have the exact same config except IP and hostname. The switchport configuration is the same.

I read somehwere something about Bonjour printing services not working well with routers. Something about Bonjour multicast to 204.x.x.x and not being able to traverse VLANs. But then again the printers and laptops are all on the same VLAN/subnet...

confused...

It "should" work if everything is on the same subnet. But I can tell you that there have been many post with others having issues with bonjour protocol. I believe others have had to enable multicast on the switch also.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***

I've read of configuring multicast on routers, but on switches? How do we do that? (They have ESW switches)

I don't know those switches. But from looking at some docs, they have a Cisco configuration assistant that you can use. I think it will be hit or miss in my opinion.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***

So this is what I found...

Bonjour check box must be checked on the ESW switch web configuration interface as well as the to enable IGMP snooping.

Gonna check sometime this week and see how it goes...

At least there is a bonjour check box. Keep me posted if you get it to work.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***

So what we had to do to get Bonjour working on our network of ESW switches and Aironet APs is to checkbox Bonjour, enable Multicast Filtering and enable IGMP. Although I'm not sure about the latter. I'm thinking about turning that off next to see if we need IGMP.

the same problem we also solved with the same actions (when were enabling multicasting over Wi-Fi for IPTV)

What about IGMP? Did you guys have that enabled or disabled?

IGMP is enabled. This protocol is needed for the users to be able to register into one of the multicast groups to watch an asked TV channel in our situation. I don't remember how it was on WLC, but on cisco switches it is enabled by default..

Bonjour talks on the IP range 224.0.0.251- multicast address.. you can try to uncheck the point of IGMP if you don't have any other multicast groups and see how would it work. but if you ever ant to work with e.g. IPTV - it should be on. Well, it is better to read about your situation deeply..

Natalia,

You need to do the following to make Bonjour printing to work.

Have multicast enabled on the wired side for all the vlans involved (management, ap manager, client, APs). if any of these vlans are not properly setup, then bonjour will not work.

Wired Side:

Router:

ip multicast-routing (enable multicast globally)

For each vlan interface enable ip pim sparse-dense-mode:

conf t

interface vlan x

ip pim spare-dense-mode (there may be a syntax error, dont have router access at the moment)

also you may need to configure a rendevouz point which you can set to layer 3 interface of the management vlan.

For example (management ip 10.1.1.10 and g/w is 10.1.1.1)

ip pim rp-address 10.1.1.1 (again syntax maybe incorrect)

Note: you will have to configure the same on all routers in between the WLC and the APs

Also make sure that the ipads/iphones and wireless printers are connected to the same ssid (same vlan). Bonjour uses link local address which are not routable.

on the WLC, set up multicast multicast mode with a unique mutlicast ip address. Also, on the multicast tab, Controller > multicast > enable global multicast.

There is a catch here. You will mostly likely have to turn off IGMP snooping on the controller (controller > multicast > disable igmp snooping).  I have learnt it the hard way that some of the apple devices dont send the igmp join reports.