cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1171
Views
0
Helpful
12
Replies

cisco aironet 1240ag access point configuration

hi i have an cisco aironet 1240ag access point i am not able to configure it it is showing radio is down, what to do for this?

12 Replies 12

Rasika Nayanajith
VIP Mentor VIP Mentor
VIP Mentor

Do you have basic config on your AP ? something like below would do

hostname <AP_HOSTNAME>
!
dot11 ssid <SSID_NAME>
   authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii <SSID_PASSWORD>
!
interface Dot11Radio0
 encryption mode ciphers aes-ccm
 ssid <SSID_NAME>
 no shutdown
!
interface Dot11Radio1
 encryption mode ciphers aes-ccm
 ssid <SSID_NAME>
 no shutdown
!
interface BVI1
 ip address dhcp

HTH

Rasika

*** Pls rate all useful responses ***

Hi sir, here i shared my current configuration

 

ARDAL-AP01#sh run
Building configuration...

Current configuration : 1144 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ARDAL-AP01
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
!
power inline negotiation prestandard source
!
!
username admin privilege 15 password 7 070E334841060B
username Cisco privilege 15 password 7 11080B01181D19
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 mbssid
 station-role root
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.230.1.10 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.230.1.254
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end

ARDAL-AP01#

The issue i faced is radio is disabled,here i shared my radio status

 

ARDAL-AP01#sh int dot11Radio 0
Dot11Radio0 is reset, line protocol is down
  Hardware is 802.11G Radio, address is 003a.9afa.1380 (bia 003a.9afa.1380)
  MTU 1500 bytes, BW 54000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/1127/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/30 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6 packets input, 377 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
ARDAL-AP01#

 

HI Vijay,

Can you console AP and reboot it.

1. Post the entire bootup process here.

2. paste the output of : sh version

3. How is it powered?

 

Reagrds

 

Hi Sandeep,

 

This ap is in remote location i am accessing through telnet only, so its little bit difficult to take the bootup process. But i will try to get it any other option is there ?

if configured ssid and vlan to the ap its showing in but radio is down only.

Here i shared the show version details.

 

ARDAL-AP01#sh ver
Cisco IOS Software, C1240 Software (C1240-K9W7-M), Version 12.4(10b)JDA3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Sun 07-Jun-09 04:13 by prod_rel_team

ROM: Bootstrap program is C1240 boot loader
BOOTLDR: C1240 Boot Loader (C1240-BOOT-M) Version 12.4(13d)JA, RELEASE SOFTWARE (fc2)

ARDAL-AP01 uptime is 1 day, 18 hours, 34 minutes
System returned to ROM by reload
System image file is "flash:/c1240-k9w7-mx.124-10b.JDA3/c1240-k9w7-mx.124-10b.JDA3"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco AIR-LAP1242G-A-K9    (PowerPCElvis) processor (revision A0) with 24566K/8192K bytes of memory.
Processor board ID FTX1718B0BQ
PowerPCElvis CPU at 262Mhz, revision number 0x0950
Last reset from reload
1 FastEthernet interface
1 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 10:F3:11:9D:49:A4
Part Number                          : 73-13787-01
PCA Assembly Number                  : 800-37048-01
PCA Revision Number                  : A0
PCB Serial Number                    : FOC17170J4V
Top Assembly Part Number             : 800-29588-03
Top Assembly Serial Number           : FTX1718B0BQ
Top Revision Number                  : A0
Product/Model Number                 : AIR-LAP1242G-A-K9

Configuration register is 0xF

ARDAL-AP01#

How is it powered?

Can you try this:

Config t

Int d0

shut

no shut

and then see the interface status again.

 

Regards

I tried it yesterday but no response, no also tried too still the same will happen

 

ARDAL-AP01(config-if)#do sh int d0
Dot11Radio0 is reset, line protocol is down
  Hardware is 802.11G Radio, address is 003a.9afa.1380 (bia 003a.9afa.1380)
  MTU 1500 bytes, BW 54000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/1127/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/30 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6 packets input, 377 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
ARDAL-AP01(config-if)#

 

I think the radio is down because you have no SSID configured see Rasika's post:

Configure SSID & configure it under the radio interfaces:

dot11 ssid <SSID_NAME>
   authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii <SSID_PASSWORD>
!

interface Dot11Radio0
 encryption mode ciphers aes-ccm
 ssid <SSID_NAME>
 no shutdown

singhmanaspratap
Beginner
Beginner

Hi,

 

Please make sure you have configured the ssid and mapped it to the radio interface. In case you have more then one ssid the configuration would be slightly changed. Please let me know with the ssid name based on which the configuration could be done.

 

Thanks and regards,

Manas Pratap Singh

Hi thanks, here i shared my requirement plz help me

i have only one vlan 

want to configure two ssid one is user and other is guest both are in open or password protected 

 

Hi Vijay,

 

With one vlan its recommended to use one ssid.

You can use the scrypt suggested by Rasika:

 


dot11 ssid test
authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii <Password>


interface Dot11Radio0
 encryption mode ciphers aes-ccm
 ssid test
 no shutdown

interface Dot11Radio1
 encryption mode ciphers aes-ccm
 ssid test
 no shutdown

 

 

 

For two ssids we would need two vlans. Incase you want two ssids please let me know the vlan numbers and ssid names.

 

Thanks and regards,

Manas Pratap Singh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers