cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
723
Views
0
Helpful
6
Replies
Highlighted
Beginner

client not getting ip

Hi, I've the following connection in my environment, and I'm using the fw as a dhcp svr. All these equipments are in the same network segment of 10.5.5.x/24. The laptop doesn't seems to get any ip from the fw, is there any port that need to be open for the ip to be assigned out, passing thru from the sw>wlc>ap back to the laptop? Thx

Laptop>ap>wlc>sw>

Sent from Cisco Technical Support

6 REPLIES 6
Highlighted

Check to see if dhcp proxy is enabled. Most FW type devices don't like the proxy the WLC does.

CLI

Show dhcp proxy

Config dhcp proxy to disable ( if it's enabled $

Can be checked from the GUI as well under Controller > DHCP

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Hi! It's enabled, will it impact other segment? Other segments r working fine getting the ip fr the windows dhcp svr. Only this segment that I'm having issue now is using the fw as dhcp. Currently this segment are used by the autonomous ap. I face the issue when I tried to get the client to connect to the converted ap (lightweight) in this segment (guest network). It's working fine for autonomous ap bcoz it's not going thru wlc. Any advise? Thx

Sent from Cisco Technical Support iPad App

Highlighted

You'll need to disable proxy to get Dhcp from the FW. make sure you add the ip helper-address to hour L3 interfaces, when you disable proxy

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Hi currently all the working segments r already configured with helper address. For this guest segment it's on vrf, the dhcp is ddirectly fr fw, thus no L3 interface. Are u referring to the guest segment or the working segment? Thx

Sent from Cisco Technical Support iPad App

Highlighted

make sure you add the ip helper-address to hour L3 interfaces  - was for the 'internal WLAN'

so all you should need to do is disable proxy, so the guest can get an address.

HTH,

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Stephen is correct here. Disabling dhcp by proxy will not adversely affect your other networks.