- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 07:49 AM - edited 04-16-2022 08:46 AM
I am working on creating a voice vlan for our Cisco WLC that I have had setup and working well the past few years. We currently have some wirless 8821 phones and I want to create a separate vlan for this. Currently they are running on a layer 2 vlan but are having some voice collisions with the data on the wireless I beleive.
I have found some good documentation on aetting up the Layer 3 for this, but have a question on the IP's for the Layer 3. In the example below for the layer 3 setup, What is the IP address refering to? Is this the switch IP or is this a static IP that I assign it to use on the port? Also, for the IP helper IP address what is this referring to? Would this be the same IP that I have already setup on the WLC?
Please see the bold text below;
Here is the example that I have.
CLI Example
1- Create the Layer 2 VLAN for Voice.
w-5760-3#conf t
w-5760-3(config)#vlan 100
w-5760-3(config-vlan)#name VoiceVLAN
w-5760-3(config-vlan)#end
w-5760-3#write mem
2- Create the Layer 3 interface for the voice VLAN.
w-5760-3(config)#interface vlan 100
w-5760-3(config-if)#no shut
w-5760-3(config-if)#ip address 10.1.1.20 255.255.255.0
w-5760-3(config-if)#description Voice VLAN
w-5760-3(config-if)#ip helper-address 10.1.1.2
w-5760-3(config-if)#end
w-5760-3#write mem
3- Add Vlan 100 on the uplink trunk connecting the WLC with the network
w-5760-3(config)#interface tenGigabitEthernet 1/0/1
w-5760-3(config-if)#switchport trunk allowed vlan 1,2,100
w-5760-3(config-if)#do sh run int te 1/0/1
interface TenGigabitEthernet1/0/1
switchport trunk allowed vlan 1,2,100
switchport mode trunk
ip dhcp snooping trust
Thank you,
Kelly
Solved! Go to Solution.
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 11:07 AM
"What is the IP address refering to? "
Is refering to the IP address of the interface vlan itself. This is going to be a Layer 3 interface from that on.
"Is this the switch IP or is this a static IP that I assign it to use on the port?"
Static IP assign to a interface vlan and can attend to any port beloging to that vlan.
For switch IP address you can use a different interface vlan or even better a loopback interface.
"Also, for the IP helper IP address what is this referring to? "
Is refering to the DHCP server.
"Would this be the same IP that I have already setup on the WLC?""
No. This IP belong to the DHCP server.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 11:34 AM
You going to use that VLAN for the new SSID you looking to create. for the new device get IP address from that range, if you have DHCP Server you need to point to that DHCP Server, so the client phone gets IP address from that range.
Same WLAN will be associated with new SSID
w-5760-3(config-if)#ip address 10.1.1.1 255.255.255.0 ( make sure there is no overlap address in your network)
w-5760-3(config-if)#description Voice VLAN
w-5760-3(config-if)#ip helper-address x.x.x.x (x.x.x.x point to your DHCP server)
create DHCP Scope for that new VLAN to allocate IP address
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 02:16 PM
You can´t use the same IP on the entire network cause you can create conflict. What you can do is use another IP from the same IP range.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 03:25 PM
Very good information and very important - much appreciated and glad I asked. That would not have worked so well.
Thanks!
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 11:07 AM
"What is the IP address refering to? "
Is refering to the IP address of the interface vlan itself. This is going to be a Layer 3 interface from that on.
"Is this the switch IP or is this a static IP that I assign it to use on the port?"
Static IP assign to a interface vlan and can attend to any port beloging to that vlan.
For switch IP address you can use a different interface vlan or even better a loopback interface.
"Also, for the IP helper IP address what is this referring to? "
Is refering to the DHCP server.
"Would this be the same IP that I have already setup on the WLC?""
No. This IP belong to the DHCP server.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 01:00 PM - edited 04-16-2022 01:30 PM
Thank you for the information. This gives me the direction to take on this.
For the wirless clients that were connecting to the access points via the vlan they are using for the DATA, will this switchport still provide the wireless connection for Layer 2 already configured on the WLC for those clients? I think it would.
Thank you,
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 11:34 AM
You going to use that VLAN for the new SSID you looking to create. for the new device get IP address from that range, if you have DHCP Server you need to point to that DHCP Server, so the client phone gets IP address from that range.
Same WLAN will be associated with new SSID
w-5760-3(config-if)#ip address 10.1.1.1 255.255.255.0 ( make sure there is no overlap address in your network)
w-5760-3(config-if)#description Voice VLAN
w-5760-3(config-if)#ip helper-address x.x.x.x (x.x.x.x point to your DHCP server)
create DHCP Scope for that new VLAN to allocate IP address
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 01:08 PM
Thank you for this information, it really helps me out.
I think I can get this configured now.
Thank you all.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 02:02 PM
When configuring the VLAN on the other switch ports, would same IP be used?
w-5760-3(config-if)#ip address 10.1.1.1 255.255.255.0 ( make sure there is no overlap address in your network)
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 02:16 PM
When configuring the VLAN on the other switch ports, would same IP be used?
same range IP not the same IP
#ip address 10.1.1.X 255.255.255.0 ( X will change)
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 03:25 PM
Very good information and very important - much appreciated and glad I asked. That would not have worked so well.
Thanks!
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
04-16-2022 02:16 PM
You can´t use the same IP on the entire network cause you can create conflict. What you can do is use another IP from the same IP range.
