cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2411
Views
0
Helpful
4
Replies

Guest Wireless webauth Redirection on Laptop

NETAD
Level 4
Level 4

Hello, I configured a guest wireless with passthrough and a customized web auth page that redirects guests to google( I also tried espn) once they hit agree. Everything works fine on an iphone but on a laptop I get this:

 

Connect to Wi-Fi 

The Wi-Fi you are using (guest-network) may require you to visit its login page.

Automatically send some system information and page content to Google to help detect dangerous apps and sites.

 

There's also a Connect button but it doesn't go anywhere.

 

Is this a browser or a cert issue or something else?

 

Thanks

4 Replies 4

Hi

 Well, for certificate issue you'd see the error asking you to accept or not. Once you do, you should be redirected.

 If you received a different message then I'd recommend you to try a different browser just to make sure.

 Also, make sure you don't have any proxy enable.

 

-If I helped you somehow, please, rate it as useful.-

Did you resolve this issue? We are having the same problem connecting with Chrome only. It gets a constant redirect loop with the warning "The Wi-Fi you are using (SSID) may require you to visit its login page." with a connect button. Connect button hits the gstatic 204 page and sends us right back.

 

EDIT: Meant to reply to the OP.

We had to disable WebAuth SecureWeb under Management---Http-Https. This requires a reboot. 

Are you hosting the WebAuth page on the WLC or an external Server?

 

if WLC, this will be related to the SSL Cert the WLC is using. Update it with a ‘proper’ Cerr from a well known Public CA and ensure you have DNS entries to match the SSL Common Name (CN) so the Browser’s security features are kept happy.

 

if you’re hosting on an external server, all of the above still applies, and ensure the ACL you’re using allows pre-authentication access to the login page.

Review Cisco Networking for a $25 gift card