Showing results for 
Search instead for 
Did you mean: 

Moving LAP's to another controller


I'm looking for some advice. We need to move some LAP's from one controller to another. There are 2 problems, one is that the LAP's are all in different locations around the country so we cant really get console access and the second is that the other controller isnt in the same mobility group, and due to politics we cant add it to the same group.

We have tried to telnet to the ap's and configure but just get ERROR!!! Command is disabled.

Software has been upgraded to 5.2.

Any ideas?!


If you can control the DNS, I would suggest making an entry for CISCO-LWAPP-CONTROLLER that points to the other controller.

Then, reset the AP to defaults (I think can be done from the controller), so the AP comes back on, resolved CISCO-LWAPP-CONTROLLER, and registers with that controller.

Now obviously if you use this entry for something else or if DHCP has entries, then you'll need to disable them, but this is the best way I can think of to get the AP on another controller without acessing it (or without having the same mobility group).


Yeah that one thing I was considering, change the DNS entry and issue clear ap-config

They said they had they had tried this when I last spoke to them but I doubt it !


How about changing the primary controller entry for each AP. It is simply an IP address and controller name.


The problem with this is that I believe the controllers need to be in the same mobility group for this to work (but I may be wrong?).


That doesnt seem to work with telnet, because the ap's are still connected to the controller they get "ERROR!!! Command is disabled". And through the GUI I think it has to be the controller by name when they are in the same mobility group.


The only reason it wouldn't work was if there was some other method in place for controller discovery (like DHCP options).

Well obviously there could be routing/firewall measure in place in the WAN preventing the AP traffic from going to other networks, but I'm guessing this has already been adressed if it was a problem.


Yes if you wipe the config. But if you simply reboot the AP with a new primary it should redirect to the primary. Again, I'd have to look at code version you're running but try it on one AP and see what happens. Apply the new primary and reboot the AP. It will either work or fail. If it fails it will fall back to the original controller. Make sure all applicable ports are open and routes to the other controller are established.


You can either clear the configuration like they mentioned above or if you want to telnet or ssh to the ap then you need to assign a username and password and allow telnet or ssh:

config ap username password


config ap telnet enable


config ap ssh enable

*** Please rate helpful posts ***
Hall of Fame Community Legend

If you want to move the AP to associate from one WLC to another, use the non-disruptive command on the WLC where the AP's are currently associated to:

config ap primary-base

Does this help?

Content for Community-Ad