Showing results for 
Search instead for 
Did you mean: 

Unable to delete mDNS profiles in WLC

Level 1
Level 1


I have some unused mDNS strings on my WLC that I would like to remove. However, when ever I try and select the option to remove the mDNS string, i get the message that the profile cannot be deleted. Please see below....

WhatsApp Image 2023-06-11 at 06.31.24.jpeg

How do I get around this? I can't find too much about this issue, any help or suggestions would be greatly appreciated.


WLC version is

4 Replies 4


 There was a Bug CSCud87413   in the version 7.4 with the exactly same behavior and I wouldn´t be surprise if this Bug is still there.

Symptom: When attempting to delete or modify an mDNS Service from an mDNS Profile, the message 'Profile is attached to one or more entities and cannot be edited' is presented by the WLC.

Conditions: The service was formerly bound to entity (wlan or interface), but mDNS Snooping was disabled on all entities before attempting to remove service.

Workaround: Enable mDNS snooping on all wlans, and select mDNS profile 'none', then delete or modify the mDNS service as needed.

It is so exactly the message that I would try to apply the   proposal workaround and see it works.

Hello Flavio,

Thank you for your response and guidance, very much appreciated. 

I have tried the suggested walk around, however this has not worked for me, I now receive another error message, please see below.


Screenshot 2023-06-17 at 12.29.25.png


Although the WLC says that the service is in use I have tried to disable it all the ways I know how, as per below. Is there anything else I am missing?

Screenshot 2023-06-17 at 12.29.42.png


 On this case, you probably need to disable the WLAN first. 

Rich R
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card