cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1152
Views
0
Helpful
4
Replies
Giulio Lo Presti
Beginner

asr9k lacp/bundle with nexus 3k and vpc

hello,

 

i have a problem in establish a lacp bundle from asr9k to 2x nexus 3k in vpc.

 

when i try to esatblish the channel without vpc everithing work correctly when i enable for example vpc 3 on port-channel on nexus the link go down and nexus say that there is a vpc mismatch.

 

i read that on ver 7 there is layer3 peer command in vpc domain submenu, it will solve my problem or not?

 

please advice.

BR

1 ACCEPTED SOLUTION

Accepted Solutions

i was able to solve this problem also, the stp cannot carry the vlans because of the port type network, after changing this the lacp works correctly. now i must upgrade the nx-os to 7.x to let the routing protocols works on vpc from nexus to asr.

 

thanks a lot for help.

 

 

View solution in original post

4 REPLIES 4
balaji.bandi
VIP Master

check the  VLAN Allowed in the vPC Peer link.

 

if still issue post both the side configuration. and error logs here.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

hello,

 

thanks for reply, i was able to establish the lag with vpc, i miss the configuration on other node, my fault, but testing the conf with only one link active i was not able to forward the test vlan. to be clear here the snippet of nexus and asr:

 

asr:

 

interface Bundle-Ether3
 lacp system mac fa16.3efd.75ee
 mac-address fa16.3efd.75ee
 bundle load-balancing hash dst-ip
 bundle maximum-active links 1 hot-standby
 bundle minimum-active links 1
!
interface Bundle-Ether3.807
 ipv4 address 2.2.2.2 255.255.255.252
 encapsulation dot1q 807

interface TenGigE0/1/0/2
 bundle id 3 mode active

nexus:

 

interface port-channel3
  speed 10000
  switchport mode trunk
  spanning-tree port type network
  vpc 3

interface port-channel10
  switchport mode trunk
  spanning-tree port type network
  no negotiate auto
  vpc peer-link

vpc domain 1
  role priority 2000
  system-priority 4000
  peer-keepalive destination 1.1.1.1 source 1.1.1.2
  auto-recovery

when i show the status of trunk on nexus on one side here is the output:

 

Po2           1       trunking      --
Po3           1       trunking      --
Po10          1       trunking      --

--------------------------------------------------------------------------------
Port          STP Forwarding
--------------------------------------------------------------------------------

Po2           1,101,112,114,116,131-132,150,157,160,187-188,200-202,501-506,508,701,801,803-807,900,999-1000
Po3           none
Po10          1,101,112,114,116,131-132,150,157,160,187-188,200-202,501-506,508,701,801,803-807,900,999-1000

as you can see the po3(the channel with asr) no vlan in forwarding

 

now the other nexus:

 

Po2           1       trunking      --
Po3           1       not-trunking  --
Po10          1       trunking      --

--------------------------------------------------------------------------------
Port          STP Forwarding
--------------------------------------------------------------------------------

Po2           1,101,112,114,116,131-132,150,157,160,187-188,200-202,501-506,508,701,801,803-807,900,999-1000
Po3           none
Po10          1,101,112,114,116,131-132,150,157,160,187-188,200-202,501-506,508,701,801,803-807,900,999-1000

the two nexus are configured the same, but on the second nexus the link is down. what i want to understand is: when a link go down the channel stop to work as expected? or i miss something?

 

thanks a lot for your advices.

 

BR

i was able to solve this problem also, the stp cannot carry the vlans because of the port type network, after changing this the lacp works correctly. now i must upgrade the nx-os to 7.x to let the routing protocols works on vpc from nexus to asr.

 

thanks a lot for help.

 

 

View solution in original post

Hello,

 

Could you describe more detail on this ? maybe the config of port type network. in which side you set it ?

 

Thank you in advance