cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2643
Views
0
Helpful
17
Replies

BGP basic configuration - iOS XR (ASR 9010).

viniicio
Beginner
Beginner

Hello dear community of CISCO,

 

My name is Vinicio. I am currently configuring a Cisco ASR9010 device but I am having difficulty configuring the BGP protocol, I would greatly appreciate it if someone could give me the steps and the sequence of steps to configure BGP.
The data of my router are the following.

 

* ASR 9010 8 Line Card Slot Chassis with V1 DC PEM
* Cisco IOS XR Software, Version 5.3.4

17 Replies 17

viniicio
Beginner
Beginner

find below an example of the configuration i am trying to applied on my router

prefix-set PASS
192.168.232.0/24,
192.168.233.0/24,
192.168.234.0/24,
192.168.235.0/24
end-set
!
route-policy GCA
pass
end-policy
!
route-policy incoming
pass
end-policy
!
route-policy outgoing
pass
end-policy
!
router bgp 100000
address-family ipv4 unicast
network 192.168.232.0/24
network 192.168.233.0/24
network 192.168.234.0/24
network 192.168.235.0/24
!
neighbor 10.0.11.1
remote-as 200000
update-source GigabitEthernet0/1/0/5
address-family ipv4 unicast
send-community-ebgp
route-policy incoming in
route-policy GCA out
send-extended-community-ebgp
default-originate
next-hop-self
!
!
!
end

Hello,

 

router bgp 100000
address-family ipv4 unicast
network 192.168.232.0/24
network 192.168.233.0/24
network 192.168.234.0/24
network 192.168.235.0/24
!
neighbor 10.0.11.1
remote-as 200000
update-source GigabitEthernet0/1/0/5 
address-family ipv4 unicast
send-community-ebgp
route-policy incoming in
route-policy GCA out
send-extended-community-ebgp
default-originate
next-hop-self

 

there is a special case for apply on this interface? Because if your interfaces fail, your routing table will reset entries. I will suggest to use a loopbackup for it to more stability.

Jaderson Pessoa
*** Rate All Helpful Responses ***

nani
Beginner
Beginner

tkarnani
Cisco Employee
Cisco Employee

What is the issue you are having?

is the neighbor down? not able to establish?

is the neighbor up? not able to advertise networks?

Hello,
@nani, thank you very much for the link i am reading it.
@Jaderson Pessoa, this was my mistake, i'm already configuring a loopback interface.
@tkarnani, my problem is that i can not establish a BGP session and likewise the neighbor is down.

Thanks for comment.

Please ping 10.0.11.1 sourcing ip of the gig interface, verify connectivity

show tcp brief | inc 179 , please verify that port is open

this looks like ebgp, please remember ebgp needs to be 1 hop away, packet is sent with ttl 1

under neighbor we can try

ebgp-multihop 10

let me know if you have any questions

 

Thanks!

@tkarnani,  thanks for the reply. I attach the results of the commands.

it looks like a tcp session is closed sourced from 2.2.2.2, is this the correct ip?

that is a Loopback0 interface. What IP address should be assigned? 


excuse me asking, what happens is that I'm not an expert in BGP.

 

 

BGP relies on TCP to handle its communication.

from the show tcp session it looks like there is a BGP session trying to establish from the loopback interface 2.2.2.2 rather than the gigabit interface which you specified.

 

can we check the forwarding to verify that we are using the gig interface?

 

show cef 10.0.11.1 detail

 

also can you provide a traceroute to 10.0.11.1

 

traceroute 10.0.11.1

@tkarnani , i made some changes in the configuration.

router bgp 267768
address-family ipv4 unicast
network 192.168.232.0/24
network 192.168.233.0/24
network 192.168.234.0/24
network 192.168.235.0/24
!
neighbor 10.0.11.1
remote-as 27708
address-family ipv4 unicast
send-community-ebgp
route-policy incoming in
route-policy GCA out
send-extended-community-ebgp
default-originate
next-hop-self
end

 

With these changes I see that already tcp has an established.  But the bgp session is not yet established.

if TCP is up that is a step in the right direction.

what is the neighborship status?

under show bgp ipv4 unicast summary, what state do we see?

Hello @tkarnani, i show the result.

RP/0/RSP0/CPU0:PANZER#show bgp ipv4 unicast summary
Mon Feb 25 09:18:15.920 GMT
BGP router identifier 10.0.11.2, local AS number 200000
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 7
BGP main routing table version 7
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 7/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 7 7 7 7 7 7

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
10.0.11.1 0 200000 48 48 7 0 0 00:04:38 1

so right now the neighbor seems to be up for 00:04:38 minutes and receiving 1 prefix

 

show bgp ipv4 unicast

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: