Hi All,
I am in the process of feature-testing the ASR9010 in our test-lab. As part of testing, I need to test interop between the ASR9010 and a Catalyst 6509 (SUP2T).
The only real road-block I've run into so far is VPLS; I am trying to get the 6509 to participate in a VPLS instance with the 9010 via BGP autodiscovery. So far no luck and documentation online seems limited.
As part of the lab setup, I have 2x ASR 9010 and 1x 6509 as PE routers, 1x ME3800X as a P router, and 1x ME3600X as a route-reflector. I have MPLS up and running, I have instantiated the vpls-vpws BGP address-family across the board, and everything is working properly.
When I run VPLS between 2x ASR 9010 with BGP autodiscovery, it works as expected. However, I am not able to get the 6509 to recognize its peers via auto-discovery.
Sample config:
PE #1: (9010)
!
interface GigabitEthernet0/0/0/3.300 l2transport
encapsulation untagged
!
l2vpn
bridge group EVPL
bridge-domain VLAN300
interface GigabitEthernet0/0/0/3.300
!
vfi EVPL_TEST
vpn-id 300
autodiscovery bgp
rd auto
route-target 65069:300
signaling-protocol bgp
ve-id 10
PE #2: (9010)
!
interface GigabitEthernet0/0/0/3.300 l2transport
encapsulation untagged
!
l2vpn
bridge group EVPL
bridge-domain VLAN300
interface GigabitEthernet0/0/0/3.300
!
vfi EVPL_TEST
vpn-id 300
autodiscovery bgp
rd auto
route-target 65069:300
signaling-protocol bgp
ve-id 30
PE #3: (6509)
!
vlan 300
name L2VPN_TEST
!
l2 vfi EVPL_TEST autodiscovery
vpn-id 300
route-target 65069:300
!
interface vlan 300
xconnect vfi EVPL_TEST
!
interface GigabitEthernet 7/1
switchport mode access
switchport access vlan 300
!
As a result, the 2x ASR 9010s can find eachother, but not the 6509. Any thoughts or feedback would be appreciated.