cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
582
Views
5
Helpful
9
Replies

Cisco Webex calling LGW - outbound calls failing, %VOICE_IEC-3-GW: SIP

kelvinteh15
Level 1
Level 1

Hi , 

Good day. 

I need some help to verify if there is any configuration issue from my end. Basically i have a registered LGW to the webex calling . The incoming call is working fine , but the outgoing call is getting the following error

Outgoing call flow as below.

My Webex App (extention) <>Internet <> Webex Calling <> Internet <> (LAN Interface) CUBE (physical connection to ITSP) <> ITSP <> My Mobile

 

%VOICE_IEC-3-GW: SIP: Internal Error (INVITE, codec mismatch)10752: Apr 23 01:12:48.066: //17073/6EA22BB0B5BB/CUBE_VT/SIP/MISC/Matched Dialpeer: Dir:Inbound, Peer-Tag: 4
10753: Apr 23 01:12:48.067: //17073/6EA22BB0B5BB/CUBE_VT/SIP/MISC/Error: sipSPIDoMediaNegotiation: Failed to negotiate main stream. Main stream dead.

Initially i though ITSP send me the error , but it look like the CUBE send the error to Webex end . with SIP/2.0 488 Not Acceptable Media

Warning: 399 10.205.16.250 "SRTP Offer/Answer not acceptable.RTP configured on dialpeer"
Reason: Q.850;cause=65 . 

Attached is the debug and show run for my system . My config is a bit difference from the Cisco documentation as the ITSP did not required authentication (SIP-UA) and i also maintain the the existing dial-peer to the CUCM where only one particular number will go to the Webex Calling. 

1 Accepted Solution

Accepted Solutions

Have you enabled all the debugs I mentioned? Log entries for the last 3 debug commands are missing completely ...

But anyway, the log says, that you match the Dial-peer 4 as inbound dial-peer.
13517: Apr 23 08:16:32.199: //19212/A098FE8FBCBA/CUBE_VT/SIP/MISC/Matched Dialpeer: Dir:Inbound, Peer-Tag: 4

But you want to match the dial-peer 200.

Dial-peer 4 is not configured for sRTP, that's why you get "488 Not acceptable Media"
Warning: 399 10.205.16.250 "SRTP Offer/Answer not acceptable.RTP configured on dialpeer"

So you dial-peer matching is not working.

Maybe because you have
dial-peer voice 200 voip
 incoming uri to 290

instead of (like in the Cisco template):
dial-peer voice 200 voip
 incoming uri request 290

Maybe there are other errors in your config, but since you masked out every important information, it's impossible to say, especially which Webex Trunk details you have inserted in your config.

View solution in original post

9 Replies 9

I think you forgot to attach the file with the debug output. From the snippet shared in the post it seems like you’re sending codecs to your service provider that they don’t accept. What codecs do you get in the SIP dialogue for an inbound call from the service provider? This is often a tell tail of what you should use for the outbound direction to the service provider.



Response Signature


Thanks. I just upload the file . 

Actually i suspect the issue on the route as the SIP traffic is send by the CUBE back to the Webex , as there is no sip traffic that i see that from ITSP send to CUBE for this call.  

Now you lost me as I’m not following what it is you’re trying to accomplish as initially you mentioned your ITSP and now you seem to say Webex Calling. Can you please outline all of the intended dial peers that you expect to be used for your particular call flow.



Response Signature


Thanks for your help . The uploaded configuraiton file may have wrongly updated when i try to hide the confidential information. Basically those are the related dial-peer. the attached file is the full config for dial peer . 

dial-peer voice 3 voip
- This dial-peer for the outgoing call(local, inter-state and mobile) to the ITSP
destinaton pattern .T

dial-peer voice 4 voip
- This dial-peer for the outgoing call (international call) to the ITSP
destination pattern +T

dial-peer voice 21 voip
- this dial-peer for the incoming call to the CUCM with the DID range
destination-pattern XXXXX....

dial-peer voice 200 voip
- this dial-peer is for the Webex app user to the CUBE (for outgoing call)
incoming uri to 290
voice class uri 290 sip
pattern dtg=(TrunkGroup OTG/DTG)

dial-peer voice 201 voip
- this dial-peer is for the incoming call from ITSP to the Webex Calling (for incoming call to the Webex App user)
destination-pattern XXXXXXXXX (Specific one number to send to Webex Calling)

"Warning: 399 10.205.16.250 "SRTP Offer/Answer not acceptable.RTP configured on dialpeer"
Reason: Q.850;cause=65 ." --> This is a very specific error message.
Are you sure, you are matching the correct dial-peers?

Could you please attach the logs of a call, with the following debugs enabled?
debug ccsip messages
debug voice ccapi ind 1
debug voice ccapi ind 2
debug voice ccapi ind 74

Here are the debug and the call flow when i use my Webex app to call the Mobile . Able to see the logs in the CUBE . I am assuming that the call should coming in to dial-peer voice 200  then go out to dial-peer voice 4 .

My Webex App (7908) <>Internet <> Webex Control Hub <> Internet <> (LAN Interface) CUBE (physical connection to ITSP) <> ITSP <> My Mobile

Have you enabled all the debugs I mentioned? Log entries for the last 3 debug commands are missing completely ...

But anyway, the log says, that you match the Dial-peer 4 as inbound dial-peer.
13517: Apr 23 08:16:32.199: //19212/A098FE8FBCBA/CUBE_VT/SIP/MISC/Matched Dialpeer: Dir:Inbound, Peer-Tag: 4

But you want to match the dial-peer 200.

Dial-peer 4 is not configured for sRTP, that's why you get "488 Not acceptable Media"
Warning: 399 10.205.16.250 "SRTP Offer/Answer not acceptable.RTP configured on dialpeer"

So you dial-peer matching is not working.

Maybe because you have
dial-peer voice 200 voip
 incoming uri to 290

instead of (like in the Cisco template):
dial-peer voice 200 voip
 incoming uri request 290

Maybe there are other errors in your config, but since you masked out every important information, it's impossible to say, especially which Webex Trunk details you have inserted in your config.

Thanks for your help . The ougoing call working fine after change to request 290 . 

Please upload the output as a text file. There are orgs that do not allow opening of compressed files from unknown parties.



Response Signature