05-15-2012 06:35 PM - edited 03-12-2019 09:46 AM
TITLE
Unable to share desktop on Jabber for Windows.
SYMPTOMS
The Desktop Sharing Option is grayed out in the Chat Window.
ENVIRONMENT
Cisco Jabber 9.0.1
Cisco Unified Communications Manager 8.6.1 and 8.6.2
Cisco Unified Presence Server 8.x (On-premises deployment)
Cisco WebEx Connect (Cloud based deployments)
CAUSES
To configure Cisco Unified Communications Manager for video desktop sharing, you need to apply a COP file to Cisco Unified Communications Manager and enable video desktop sharing on the SIP profiles of CSF devices.
RESOLUTION
Configuring Desktop Sharing on CUCM 8.6.1 -
On the CUCM Admin page –
Configuring Desktop Sharing on CUCM 8.6.2 -
On the CUCM –
1. Upload and apply the ‘cmterm-bfcp-e.8-6-2.cop.sgn ‘ COP file for desktop sharing, you can download the Admin folder on the following link to get access to the same.Note: - As of this release, Cisco Jabber for Windows supports video desktop sharing in software phone mode only. Video desktop sharing is not available in desk phone mode.
- You cannot enable video desktop sharing on the default SIP profile. You can copy the default SIP Profile and save it as a new one.
RELATED TOPICS
I am using this in version 8.6.1 and the Share Desktop Option is greyed out even though i have followed the steps for V 8.6.1
Do I need to apply and upload the COP file for this version? This is the only step I havent done and it is stated as not needed for this version.
Yes COP file is required for this feature.
Im using version 8.6.2 as it happens.
So I have installed the COP file, documentation states that I must restart the Publisher server for this to take effect as well as all the other nodes.
Can you please re-confirm that all nodes have to be re-started (I have 8 nodes and it will take some time.
Hi there,
I have tested my XML file contents on a non-CSF device
Verified as working:
The disallowed file types work for CSF and Non CSF Device (Jabber Clients)
I didnt expect this to work but it has, thats great!
Hey Navidp,
As for restarting the CCM Server, that is necessary as you are introducing a new configuration. So we must restart the Servers after the COP file install so that this new functionality will work successfully.
Also, good to hear about Non-CSF device working for restricting file types. As mentioned earlier, CSF is only to allow soft phone feature for Cisco Jabber.
Regards,
Jasmeet
Hi there,
Can you verify whether every node in the cluster needs rebooting?
To re-boot the PUB (to which the COP file was uploaded) is not bad and ok to manage
To reboot 2x TFTP servers and 5 x CallManagers needs to be a controlled change and will take some time.
I have an update from our Dev Team:
The COP file adds more than just database entries, hence why it needs to be applied on each CUCM server in the cluster. The basic DB replication is not enough and so we have to restart each of the Call Manager in the cluster
So you will ahve to submit a change request and follow through the procedure.
Regards,
Jasmeet
I have uploaded the COP file to the publisher.
Just to re-confirm, Restart all Servers in Cluster starting with the publisher node?
Hi Navdip,
Please follow the below instructions once you have provisioned your CUCM 8.6.2 node/s with the bfc Device File (cmterm-bfcp-e.8-6-2.cop.sgn ‘) on each CUCM node then restarted each CUCM node, Created a New SIP Profile(cannot use default but recommend copying it to create new profile) and enabled the “Allow Presentation Sharing using BFCP” to the new SIP Profile then assign the new profile to the Client Service Framework Devices and enabled the “Allow Presentation Sharing using BFCP” under the CSF devices as well followed by a device reset.
Note: Only CUCM 8.6.1 and 8.6.2 and later support this feature
RE:
http://www.cisco.com/en/US/docs/voice_ip_comm/jabber/Windows/9_0_1/b_jabber_win_icg_chapter_010.html#task_002CD757B8EC4F5E85AA5222626C772B
Here’s what the screens will look like if you have properly configured CUCM for Desktop Sharing:
4. Once you are sharing the desktop, you have the option to stop sharing if you are sharing your desktop and if the other user is seeing your desktop, they have the option to Take Over Control or go to Full Screen Menu by selecting either of the two options in the below screenshot:
Navdip,
And yes, you must restart every CUCM node in the cluster starting with the publisher.
Hi, I´m using CUCM 8.5.1.10000-26 Unrestricted and CUPS 8.0.3.10000-4, I´ve everithing working but share desktop is not, it is in grey, do i need to upgrade to version 8.6 the callmanager?
Regards.
Carlos
Hey Carlos,
You do indeed need to be on either CCM 8.6(1) or 8.6(2) to be able to do Desktop Sharing.
Regards,
Jasmeet
When an audio call or video was established between (2) Jabber clients, the Desktop Share was still grayed out. Everything else was working fine
What's missing here?
Hey Tommer,
Make sure you are using Cisco Jabber in Soft Phone Mode as currently, as of this release, Cisco Jabber for Windows supports video desktop sharing in software phone mode only. Video desktop sharing is not available in desk phone mode.
It's a planned feature for next release.
Let me know if it still doesn't work in Soft Phone Mode.
Regards,
Jas
Has anyone seen an issue where you can't share your desktop if you use click-to-call off the buddy list, but you can share desktops if you manually dial the number? We're experiencing this.
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