cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
578
Views
0
Helpful
1
Replies

AudiumElementBase cannot be resolved to a type


Hi All,

I am attempting to modify  an existing Java class in an existing call studio project.  The changes have been quite simple but I am struggling to re-compile so I can create a new java class.

The steps I have taken are

  • Decompiled existing class
  • Made small change to java
  • Crreate new project in Call Studio (v9) - added external jars to library  element.jar, framework.jar, servlet.jar
  • Created new class
  • Copied in new modified java
  • When I went to build project I see a few errors and the suggestion was to

    • Import com.audium.server.AudiumException
    • Import com.audium.server.session.ActionElement
    • Import com.audium.server.voiceElement.ActionElementBase
  • For each of these though I now get a problem generated saying
    • ActionElementBase cannot be resolved to a type
    • ActionElementData cannot be resolved to a type
    • AudiumException cannot be resolved to a type

I have seen a couple of other old posts on this and the fix seemed to be adding in the external jars but this is not working here.  Any help would be greatly appreciated.

Thanks!

Message was edited by: Cathal O'Driscoll I sorted it out. Not sure why it wasn't working but I deleted the project and started again from scratch. I followed the same steps and this time it worked. Cheers

1 Accepted Solution

Accepted Solutions

hemajosh
Level 4
Level 4

Good to see that it worked for you.

View solution in original post

1 Reply 1

hemajosh
Level 4
Level 4

Good to see that it worked for you.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: