cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
171
Views
0
Helpful
2
Replies
Highlighted
Beginner

Finesse layout not populated when using Connect Step

I'm working on a script that would send a call to an agent regardless of finesse state. I have it working well using the connect step, however the finesse layout does not get populated with Enterprise data that is set from a database dip. Is this normal functionality or is there another step I'm missing? 

I am setting the resource from database dip as well not from CSQ. 

I should mention that the finesse layout is populated with the correct data when the call is sent to an agent using the Select Resource Step. 

 

Running UCCX 10.6.1

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Re: Finesse layout not populated when using Connect Step

Hold up. You're using the Connect step, without first using the Select Resource step?  I'm surprised it even did anything, and bravo to you for attempting to use it without reading the documentation.  You're a real life cowboy, and I like it!

 

uccx-connet.png

 

What you are probably looking to do is, use the Select Resource step, but switch it to Agent Based routing instead.  I'm positive your Finesse layout will now work.

 

uccx-select-resource.png


Anthony Holloway

View solution in original post

2 REPLIES 2
Highlighted
VIP Mentor

Re: Finesse layout not populated when using Connect Step

Hold up. You're using the Connect step, without first using the Select Resource step?  I'm surprised it even did anything, and bravo to you for attempting to use it without reading the documentation.  You're a real life cowboy, and I like it!

 

uccx-connet.png

 

What you are probably looking to do is, use the Select Resource step, but switch it to Agent Based routing instead.  I'm positive your Finesse layout will now work.

 

uccx-select-resource.png


Anthony Holloway

View solution in original post

Highlighted
Beginner

Re: Finesse layout not populated when using Connect Step

I read the documentation after posting and tried again. It worked after nesting in the Select Resource step using the mentioned agent based routing method but only when agent was in a Ready state, doesn't look like sending a call to an agent when in not ready state is possible with showing the layout. Going to have to rethink this. 
Thanks for the input.  

 

CreatePlease to create content
Content for Community-Ad
Future of Work Virtual Summit Day 5

Cisco COVID-19 Survey