cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
630
Views
5
Helpful
2
Replies
Highlighted
Beginner

Mediaserver / Mediaserver-backup not working when VXML server service is down

Good Evening

 

I am currently experiencing an issue whereby the mediaserver and mediaserver-back up is not working correctly when the VXML server is shutdown on the primary side of the deployment, despite having the secondary side readily available. If the CVP primary Call server is shut down as well, it fully fails over to the secondary Call/VXML server and works perfectly fine. Both DNS entires have been configured on the IOS gateway and on VVB using the host-to-ip command.

 

I have tested this scenario both with Virtualized Voice Browser and VXML IOS Gateway and both scenarios appear to fail. The node with “Mediaserver” is specified within the ICM script and works perfectly fine providing that both services are started on a single CVP server.

 

The UCCE solution is running version 11.6.1 and collaboration version 11.5. This issue also appears if you stop the primary call server and leave the secondary VXML and Call server running. The issue has been tested within a lab environment and also has the same results as a production environment.

 

I have raised a Cisco TAC case regarding this, however I am just wondering If any of the community has experienced this issue? I don’t recall this happening before. I’ve never really been in the situation where the VXML server service is stopped on its own.

 

Any assistance will be greatly appreciated.

 

Many thanks,

Everyone's tags (7)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Mediaserver / Mediaserver-backup not working when VXML server service is down

Hi,

 

This has been resolved by modifying the SIP.properties file located within the CVP installation directory.

 

The following needs to be amended from "False" to "True":

 

SIP.UseBackupIVRSS=true

 

After the restart, it seems to be working fine.

 

Many thanks for your contribution.

2 REPLIES 2
Beginner

Re: Mediaserver / Mediaserver-backup not working when VXML server service is down

Hi,

 

To my knowledge this is working as designed. As of CVP 11.5 microapps run off the VXML Server service. So I believe this would be applicable to either running a simple microapp (PM, Menu, etc..) as well as attempting to call a VXML application/Studio app.

 

What you'll see in the VVB logs (assuming same as in IOS VB though I've not looked there), is that the voice browser will attempt to fetch the VXML application from whatever IP and/or whatever mediaserver IP resolves to, fails, and then builds the backup media server URL as <primary cvp call server hostname>-backup.

 

For example, I have my VXML server defined in CVP ops with a primary call server of CVPA01. When we call an application we  had the media_server ecc variable to "mediaserver" and have corresponding entry on VVB to point mediaserver to 192.168.1.10.

 

So VXML server is shut down on that 192.168.1.10. In VVB logs you'll see it try to fetch the application first at http://192.168.1.10:7000/CVP/Server and throw a message about "Couldn't contact IVR service". Then we'll see it build the backup URL of http://CVPA01-backup:7000/CVP/Server.

 

So as long as on your VVB and/or IOS VB you have the appropriate settings for host-to-ip or ip host <CVP Call Server hostname>-backup then this will failover properly to the backup VXML server.

 

Long story short, the mediaserver and mediaserver-backup comes into play for media fetches and will use that accordingly, but not for actually calling the applications on VXML Server. Why - I wish I knew, but this is what I've found though it would make more sense to use media or mediaserver (or however you define your default media servers etc..). Simple solution would be to add in the corresponding host-to-ip and/or ip host entries on each side. I.E. A side VVB has host-to-ip for <A side CVP hostname>-backup pointed to the IP of the B side CVP hostname, and vice versa. 

Beginner

Re: Mediaserver / Mediaserver-backup not working when VXML server service is down

Hi,

 

This has been resolved by modifying the SIP.properties file located within the CVP installation directory.

 

The following needs to be amended from "False" to "True":

 

SIP.UseBackupIVRSS=true

 

After the restart, it seems to be working fine.

 

Many thanks for your contribution.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards