cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
735
Views
5
Helpful
6
Replies

UCCX Transcoder Usage for internal call

shaijal.allipra
Beginner
Beginner

 

I have builded LAB setup with CUCM and UCCX. I have created test application, I am getting welcome greeting when I dial from 3CX SIP Phone. However when I dial from my CIPC Call getting failed with following error. I have only one region and codec is 711. Not sure why I need XCODE. I already have hardware MTP resource. In this setup do I need hardware media resource? 

CUCM - 12.0.1.24900

 

Attached Call manager logs, few lines are below


00455691.023 |15:41:00.867 |AppInfo |DET-MediaManager-(4)::sendMTPXcoderAllocationRequest, (CapCount,Region),SideA:(6,LAB_Region), SideB:(2,LAB_Region), supressMatchCap=0,MTPNeededForDTMF=0
00455691.024 |15:41:00.867 |AppInfo |SIG-MediaManager-(4)::sendMTPXcoderAllocationRequest, allocate xcoder(ci=24642640), suppressMatchCap=0, mrgl=374abf8d-643b-7344-a7c2-c63a3db2102a DeviceCapsReqdMask=0x0
00455691.025 |15:41:00.867 |AppInfo |DET-MediaManager-(4)::allocateProxies, j=1 XferMode(4 0) CI(24642639 0) mrid(0 0) resrcCI(0 24642640)
00455691.026 |15:41:00.867 |AppInfo |SIG-MediaManager-(4)::allocateProxies, allocating resources(1), additional res(0)
00455692.000 |15:41:00.867 |SdlSig |MrmAllocateXcoderResourceReq |waiting |MediaResourceManager(1,100,142,1) |MediaManager(1,100,144,4) |1,200,13,3.8010^10.210.223.12^CCXpt_120003 |[R:N-H:0,N:0,L:0,V:0,Z:0,D:0] CI=24642640 MRGLPkid=374abf8d-643b-7344-a7c2-c63a3db2102a Kpbs=0 RegionA=LAB_Region CapA=6 RegionB=LAB_Region CapB=2 SuppressFlag=0 Type=1 DeviceCapablity= [0x0]0 MandatoryCapabilties= [0x0]0 Count=1
00455692.001 |15:41:00.867 |AppInfo |MediaResourceManager::waiting_MrmAllocateXcoderResourceReq - CI=24642640, Count=1
00455692.002 |15:41:00.867 |AppInfo |MediaResourceManager::waiting_MrmAllocateXcoderResourceReq - CREATING CHILD USING MRGL LIST
00455692.003 |15:41:00.867 |AppInfo |MRM::convertScmStringToStdString LAB_MRG
00455692.004 |15:41:00.867 |AppInfo |MRM::getXcodeDeviceGivenMrgl
00455692.005 |15:41:00.867 |AppInfo |MRM::getXcodeDeviceGivenMrgl GETTING XCODE FROM DEFAULT LIST
00455692.006 |15:41:00.867 |AppInfo |MediaResourceManager::sendAllocationResourceErr - ERROR - no transcoder device configured

6 REPLIES 6

jim-j
Beginner
Beginner

In your UCCX call control group have you tried setting "Media Termination Support" to "No"?

Is your CIPC set to low bandwidth?  G729 to G711 would require a transcoder.

BTW CIPC is EOL, you really should be migrating away from it.

Thanks, Yes Media Termination Support" set to "No" and CIPC set to low. I have changed MTP to Yes, but still call failing. When I use XCODE call going through 

You probably want "Media Termination Support" set to "No" (as I elaborate below, this Media Termination Support is not related to this)

CIPC set to low bandwidth is almost certainly causing your problem.


@jim-j wrote:

In your UCCX call control group have you tried setting "Media Termination Support" to "No"?


Sorry my UCCX call control group "Media Termination Support" question was a red herring.  This setting has nothing to do with MTPs, transcoding, etc.  Just thought I better correct myself in case someone else finds this post later.  It really doesn't matter if you have this set to yes or no.  Unless you know that you need it, might as well leave it set at its default of no.

 

Setting "Media Termination Support" to yes only causes UCCX to automatically create a CMT group (CCX Admin > Subsystem > Cisco Media).

Elliot Dierksen
VIP Collaborator VIP Collaborator
VIP Collaborator

It could also be that the MRG where the transcoders are assigned is higher in the MRGL for the CTI ports than the MRG with the MTP's. CCX only supports out of band DTMF relay, so that will frequently cause CCX to request an MTP. A transcoder is an MTP, but one with enhanced capabilities. I prefer to keep the transcoders less preferred in the MRGL so that that aren't allocated when an MTP is what is needed. That keeps the transcoders available for calls that do actually require transcoding service.

Actually looking at the debug further, I believe that @jim-j is correct. CCX is requesting a transcoder, and CIPC set to low bandwidth is almost certainly the cause.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: