cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
250
Views
15
Helpful
5
Replies

[Unified Contact Center Express 12.5] chat session gets disconnected

Hello, 

I am trying to test the Cisco chat feature provided by Unified Contact Center Express 12.5, and getting the following error "Chat disconnected due to inactivity or connection failure.". Please advise on what needs to be done to make the chat widget working with the Agent desktop.

 

Below are performed steps.

1. Provisioned Unified Contact Center Express 12.5 environment.

2. Connect to the windows server and log in to the agent(Agent001) into Jabber phone.

3. Logged in to Finesse Agent Desktop using firefox, Made agent ready for Phone, Chat, and Email.

 

To test the Chat widget

  1. Login an agent into the Finesse Agent Desktop. See the Finesse tab for instructions.
  2. Click the Manage Chat And Email button in the left panel navigation.
  3. Click on Chat and email icons on the header and under Chat and Email, change the agent to Ready state to receive chat and emails.
    If you see the error "Chat temporarily down due to outages", restart the Cisco Unified CCX Engine and try again.
  4. When a chat is sent to the queue that the agent belongs to (See the table below), a popover will appear to accept the chat request. It will also display in the Manage Chat and Email gadget.

 

Customer Instructions

  1. Open the Chat widget link(from local workstation)
  2. Fill out the form. For the "Choose a category" field, select the queue that the logged in agent belongs to (See the table below).
  3. Click the Submit button
  4. The window should refresh with a chat interface. Chat with the agent on this page.

Does anybody know what the issue and could provide any guidance that would be helpful?

 

Thank you 

 

1 ACCEPTED SOLUTION

Accepted Solutions
dekwan
Cisco Employee

Hi,

 

Based on your screenshots, I am assuming you are using the DevNet UCCX 12.5 sandbox. I was able to reproduce your issue while opening the chat widget on Chrome, but the issue was not reproducible on Firefox. I know for a fact that I had used this chat gadget on Chrome before, so maybe a recent Chrome update broke the widget. I will investigate, but in the meantime, can you see if it is working for you on firefox?

 

Thanx,

Denise

View solution in original post

5 REPLIES 5
dekwan
Cisco Employee

Hi,

 

Based on your screenshots, I am assuming you are using the DevNet UCCX 12.5 sandbox. I was able to reproduce your issue while opening the chat widget on Chrome, but the issue was not reproducible on Firefox. I know for a fact that I had used this chat gadget on Chrome before, so maybe a recent Chrome update broke the widget. I will investigate, but in the meantime, can you see if it is working for you on firefox?

 

Thanx,

Denise

View solution in original post

dekwan
Cisco Employee

Hi,

 

Looks like this is a result of the bug CSCvt76008 (https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvt76008). I tested out the workaround and it fixed the issue:

* SameSite by default cookie flag may be disabled on customer side under chrome://flags/#same-site-by-default-cookies.

 

Thanx,

Denise

Hi Denise,

 

Thank you for your reply.

I changed the browser to Firefox and it worked.

 

Hello @dekwan ,


I am exploring Chat API for UCCE, found on URL https://developer.cisco.com/docs/enterprise-chat-and-email/#!interaction-api-developer-guide

Can you please guide me on what is the server/cisco component where I should be calling those endpoints?.
I could not found any useful example on which cisco component should those API calls go to.
Could you please provide any such sample documents/examples stating that?.

Thank you
Himanshu

Hi,

 

Looks like you already emailed the alias ask-ece-dev@external.cisco.com with this question. That is the best route of support for ECE.

 

Thanx,

Denise

Content for Community-Ad