cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1462
Views
0
Helpful
3
Replies

[virtualbox][solution] UCCX editor hangs at 81% "Starting com.cisco.file.FileManager manager"

famcbwolfe
Level 1
Level 1

Hey guys, just wanted to post this here so it's documented somewhere.

If you're running windows in a virtualbox environment, and you run into an issue where UCCX editor hangs at 81% for a while -- finally loads, but won't actually connect to your CCX node (e.g. reactive script debug doesn't work, viewing the script repository doesn't work), I believe I've found a solution.

I've been racking my brain on this for the last couple hours, tried uninstalling and reinstalling, manually swapping out java versions, deleting every registry key I could find, to no avail. Then I fired up wireshark and looked at the traffic, and noticed a couple of tcp retransmits coming from the UCCX node. Just on a whim, I changed my guest's interface to a bridged interface, rather than 1:1 NAT, and everything immediately started working as expected (and no more retransmits!).

There's a small chance this might not have anything to do with virtualbox's gateway -- maybe it's just because my dhcp server hands me option 15 and 119, whereas virtualbox's dhcp server doesn't.

So yeah.. this isn't a question -- just hoping this helps someone googling for this issue 6 months down the road.

3 Replies 3

Anthony Holloway
Cisco Employee
Cisco Employee

Thanks for sharing this.  The 81% file.FileManager issue has been discussed a few times on the forums without resolution.

https://supportforums.cisco.com/thread/268952

https://supportforums.cisco.com/thread/2002816

Anthony Holloway


Please use the star ratings to help drive great content to the top of searches.

tomas.truchly
Level 1
Level 1

Well to me this problem occurs when I forget and try to save some/any script directly to database instead of saving it on the drive and uploading manually. 

Let me repeat. This is exactly how I can end up in a situation like this. 

 

It works normally for me. I can launch CCX Editor with Log In. So I can do live debugs I can load a script from database. 

But I can never save to database. Instead I have to save scripts on my drive and then upload them via web interface.

If I forget myself and try to save script in DB. It hangs forever. 

Then if I kill UCCX and relaunch it will get stuck exactly in 81% as in your case. 

 

This is production CC and I don't want to restart it. So I will wait for 20 minutes and see if there will be some timeout. 

By the way, if you're using the UCCX Application Administrator account to login to the Editor, you will not be able to save files to the server directly, its not a feature. I'm not sure if that's what you're doing or not, but I thought I'd mention it, just in case you wanted to save directly to the server in the future. To do so, you will need to login to the Editor with one of the administrator accounts which are created in CUCM End Users and assigned as Administrators in UCCX AppAdmin instead.