cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
856
Views
5
Helpful
4
Replies
Highlighted
Beginner

7841 doesn't register on CME 12.x while lower versions are ok

Hello guys,

 

I have got ISR 4331 with CME 12.3 and can't get 7841 phones registered. After they download their config files they get stuck in "Registration in progress".

 

IOS isr4300-universalk9.16.09.02.SPA.bin

FW sip78xx.12-0-1-11.loads

 

If I downgrade to CME 11.x or 10.x all is ok without any change to config.

If I configure phone 7960 it faces no problem at all.

Different FW versions of the 7841make no difference.

 

Is there a limitation in use of 7841 under 12.3 on 4300??

 

Below sh run and debug tftp packets and debug voice register events/errors.

 

Many thanks for your ideas.

 

Martin

 

 

 

version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
service call-home
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R4331
!
boot-start-marker
boot system flash isr4300-universalk9.16.09.02.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
enable password voip
!
no aaa new-model
!
!
!
!
!
!
!
ip dhcp excluded-address 172.31.15.1 172.31.15.99
!
ip dhcp pool PHONES
network 172.31.15.0 255.255.255.0
default-router 172.31.15.1
option 150 ip 172.31.15.1
option 42 ip 172.31.15.1
dns-server 4.2.2.2
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto pki trustpoint SLA-TrustPoint
enrollment pkcs12
revocation-check crl
!
!
crypto pki certificate chain SLA-TrustPoint
certificate ca 01
30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030
32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363
6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934
3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305
43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720
526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030
82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D
CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520
1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE
4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC
7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188
68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7
C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191
C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44
DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201
06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85
4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500
03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905
604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B
D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8
467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C
7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B
5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678
80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB
418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0
D697DF7F 28
quit
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
mode cme
source-address 172.31.15.1 port 5060
max-dn 20
max-pool 10
load 7960-7940 P0S3-8-12-00
load 7841 sip78xx.12-0-1-11
authenticate register
timezone 28
url directory http://172.31.15.1/localdirectory
tftp-path flash:
create profile sync 0095442216529147
!
voice register dn 1
number 300
name Test 1
!
voice register dn 2
number 310
name Test 2
!
voice register dn 5
number 305
!
voice register pool 1
busy-trigger-per-button 2
id mac 0045.1D6B.9B10
type 7841
number 1 dn 1
username phone1 password cisco
!
voice register pool 2
busy-trigger-per-button 2
id mac 0045.1D6B.9B51
type 7841
number 1 dn 2
username phone2 password cisco
codec g711alaw
!
voice register pool 3
id mac 0015.C6E8.D59D
type 7960
number 1 dn 5
username phone3 password cisco
!
!
!
!
!
voice-card 0/4
dsp services dspfarm
no watchdog
!
no license feature hseck9
license udi pid ISR4331/K9 sn FDO22450X7Z
license accept end user agreement
license boot level appxk9
license boot level uck9
license boot level securityk9
no license smart enable
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
!
redundancy
mode none
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
description towards r4
ip address 10.0.70.2 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/1
description To L2 SW3 with phones
ip address 172.31.15.1 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
!
interface Service-Engine0/4/0
no ip address
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
ip ftp username martin
ip ftp password test
ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 10.0.70.1 200 name R4
!
!
!
!
tftp-server flash:/sip78xx.11-1-2MSR1-1/kern2.78xx.11-1-2MSR1-1.sbn alias kern2.78xx.11-1-2MSR1-1.sbn
tftp-server flash:/sip78xx.11-1-2MSR1-1/rootfs2.78xx.11-1-2MSR1-1.sbn alias rootfs2.78xx.11-1-2MSR1-1.sbn
tftp-server flash:/sip78xx.11-1-2MSR1-1/sboot2.78xx.11-1-2MSR1-1.sbn alias sboot2.78xx.11-1-2MSR1-1.sbn
tftp-server flash:/sip78xx.11-1-2MSR1-1/sip78xx.11-1-2MSR1-1.loads alias sip78xx.11-1-2MSR1-1.loads
tftp-server flash:kern2.78xx.12-5-1-16.sbn alias kern2.78xx.12-5-1-16.sbn
tftp-server flash:kern78xx.12-5-1-16.sbn alias kern78xx.12-5-1-16.sbn
tftp-server flash:rootfs2.78xx.12-5-1-16.sbn alias rootfs2.78xx.12-5-1-16.sbn
tftp-server flash:rootfs78xx.12-5-1-16.sbn alias rootfs78xx.12-5-1-16.sbn
tftp-server flash:sboot2.78xx.12-5-1-16.sbn alias sboot2.78xx.12-5-1-16.sbn
tftp-server flash:sboot78xx.12-5-1-16.sbn alias sboot78xx.12-5-1-16.sbn
tftp-server flash:sip78xx.12-5-1-16.loads alias sip78xx.12-5-1-16.loads
tftp-server flash:kern2.78xx.12-0-1-11.sbn alias kern2.78xx.12-0-1-11.sbn
tftp-server flash:kern78xx.12-0-1-11.sbn alias kern78xx.12-0-1-11.sbn
tftp-server flash:rootfs2.78xx.12-0-1-11.sbn alias rootfs2.78xx.12-0-1-11.sbn
tftp-server flash:rootfs78xx.12-0-1-11.sbn alias rootfs78xx.12-0-1-11.sbn
tftp-server flash:sboot2.78xx.12-0-1-11.sbn alias sboot2.78xx.12-0-1-11.sbn
tftp-server flash:sboot78xx.12-0-1-11.sbn alias sboot78xx.12-0-1-11.sbn
tftp-server flash:sip78xx.12-0-1-11.loads alias sip78xx.12-0-1-11.loads
!
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
telephony-service
max-conferences 8 gain -6
transfer-system full-consult
directory entry 1 300 name Test 1
directory entry 2 310 name Test 2
!
!
dial-peer voice 200 voip
description To SRST
destination-pattern 2..
session protocol sipv2
session target ipv4:10.0.60.2
!
!
!
line con 0
exec-timeout 60 0
login
transport input none
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password voip
login
transport input telnet
!
ntp server 172.31.15.1
!
!
!
!
!
end

 

 

 

 

*Feb 7 13:01:40.031: TFTP: Server request for port 51669, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:40.031: TFTP: read request from host 172.31.15.100(51669) via GigabitEthernet0/0/1
*Feb 7 13:01:40.031: TFTP: Looking for CTLSEP00451D6B9B10.tlv
*Feb 7 13:01:40.031: TFTP: Sending error 1 No such file
*Feb 7 13:01:40.801: TFTP: Server request for port 51820, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:40.801: TFTP: read request from host 172.31.15.100(51820) via GigabitEthernet0/0/1
*Feb 7 13:01:40.801: TFTP: Looking for ITLSEP00451D6B9B10.tlv
*Feb 7 13:01:40.801: TFTP: Sending error 1 No such file
*Feb 7 13:01:41.564: TFTP: Server request for port 49359, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:41.564: TFTP: read request from host 172.31.15.100(49359) via GigabitEthernet0/0/1
*Feb 7 13:01:41.564: TFTP: Looking for ITLFile.tlv
*Feb 7 13:01:41.564: TFTP: Sending error 1 No such file
*Feb 7 13:01:43.116: TFTP: Server request for port 49818, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:43.116: TFTP: read request from host 172.31.15.100(49818) via GigabitEthernet0/0/1
*Feb 7 13:01:43.116: TFTP: Looking for SEP00451D6B9B10.cnf.xml
*Feb 7 13:01:43.139: TFTP: Opened flash:/its/SEP00451D6B9B10.cnf.xml, fd 0, size 4807 for process 399
*Feb 7 13:01:43.140: TFTP: Sending block 1 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.141: TFTP: Received ACK for block 1, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.142: TFTP: Sending block 2 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.143: TFTP: Received ACK for block 2, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.143: TFTP: Sending block 3 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.144: TFTP: Received ACK for block 3, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.144: TFTP: Sending block 4 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.145: TFTP: Received ACK for block 4, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.146: TFTP: Sending block 5 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.147: TFTP: Received ACK for block 5, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.147: TFTP: Sending block 6 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.148: TFTP: Received ACK for block 6, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.152: TFTP: Sending block 7 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.153: TFTP: Received ACK for block 7, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.153: TFTP: Sending block 8 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.154: TFTP: Received ACK for block 8, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.155: TFTP: Sending block 9 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.156: TFTP: Received ACK for block 9, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.156: TFTP: Sending block 10 (retry 0), len 199, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.158: TFTP: Received ACK for block 10, socket_id 0x7FC65CD1B078
*Feb 7 13:01:43.158: TFTP: Finished flash:/its/SEP00451D6B9B10.cnf.xml, time 00:00:00 for process 399
*Feb 7 13:01:49.956: TFTP: Server request for port 49297, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:49.957: TFTP: read request from host 172.31.15.100(49297) via GigabitEthernet0/0/1
*Feb 7 13:01:49.957: TFTP: Looking for SIP_English_United_States/sp-sip.jar
*Feb 7 13:01:49.957: TFTP: Sending error 1 No such file
*Feb 7 13:01:50.847: TFTP: Server request for port 49572, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:50.847: TFTP: read request from host 172.31.15.100(49572) via GigabitEthernet0/0/1
*Feb 7 13:01:50.848: TFTP: Looking for SIP_United_States/g3-tones.xml
*Feb 7 13:01:50.848: TFTP: Sending error 1 No such file
*Feb 7 13:01:51.836: TFTP: Server request for port 49229, socket_id 0x7FC65CD1B078 for process 399
*Feb 7 13:01:51.837: TFTP: read request from host 172.31.15.100(49229) via GigabitEthernet0/0/1
*Feb 7 13:01:51.837: TFTP: Looking for softkeyDefault_kpml.xml
*Feb 7 13:01:51.847: TFTP: Opened flash:/its/softkeyDefault_kpml.xml, fd 0, size 5290 for process 399
*Feb 7 13:01:51.848: TFTP: Sending block 1 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.850: TFTP: Received ACK for block 1, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.850: TFTP: Sending block 2 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.851: TFTP: Received ACK for block 2, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.851: TFTP: Sending block 3 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.853: TFTP: Received ACK for block 3, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.853: TFTP: Sending block 4 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.854: TFTP: Received ACK for block 4, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.855: TFTP: Sending block 5 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.856: TFTP: Received ACK for block 5, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.856: TFTP: Sending block 6 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.858: TFTP: Received ACK for block 6, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.858: TFTP: Sending block 7 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.860: TFTP: Received ACK for block 7, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.860: TFTP: Sending block 8 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.861: TFTP: Received ACK for block 8, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.861: TFTP: Sending block 9 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.862: TFTP: Received ACK for block 9, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.863: TFTP: Sending block 10 (retry 0), len 512, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.864: TFTP: Received ACK for block 10, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.864: TFTP: Sending block 11 (retry 0), len 170, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.865: TFTP: Received ACK for block 11, socket_id 0x7FC65CD1B078
*Feb 7 13:01:51.865: TFTP: Finished flash:/its/softkeyDefault_kpml.xml, time 00:00:00 for process 399

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: 7841 doesn't register on CME 12.x while lower versions are ok

Hi,

I have it fixed.

I tested out few more FWs and found that those with SR in their name work while others not.

An example of FWs that cause registration issue for 7841 on CME 12.x (but works with 10.x and 11.x):
sip78xx.11-5-1-18.loads
sip78xx.12-0-1-11.loads
sip78xx.12-5-1-16.loads

Works with 12.x:
sip78xx.11-5-1SR1-1.loads
sip78xx.12-1-1SR1-4.loads
sip78xx.12-5-1SR1-4.loads

Any idea what does the SR mean it the name?!? I can't google it out...

Thanks,
Martin

View solution in original post

4 REPLIES 4
Highlighted
Hall of Fame Master

Re: 7841 doesn't register on CME 12.x while lower versions are ok

Have you tried factory reset on the phone?

Highlighted
Beginner

Re: 7841 doesn't register on CME 12.x while lower versions are ok

Hello Chris,

 

yes I did. A few times.

 

Martin

Beginner

Re: 7841 doesn't register on CME 12.x while lower versions are ok

Hi,

I have it fixed.

I tested out few more FWs and found that those with SR in their name work while others not.

An example of FWs that cause registration issue for 7841 on CME 12.x (but works with 10.x and 11.x):
sip78xx.11-5-1-18.loads
sip78xx.12-0-1-11.loads
sip78xx.12-5-1-16.loads

Works with 12.x:
sip78xx.11-5-1SR1-1.loads
sip78xx.12-1-1SR1-4.loads
sip78xx.12-5-1SR1-4.loads

Any idea what does the SR mean it the name?!? I can't google it out...

Thanks,
Martin

View solution in original post

Highlighted

Re: 7841 doesn't register on CME 12.x while lower versions are ok


Hi there,

 

This should be a bug because it just happened to me, I uploaded the SR firmware and after the phone got the new file I saw then registering .

CreatePlease to create content