cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
519
Views
5
Helpful
4
Replies
Matt Glosson
Beginner

9971 SIP Phone Calling Problems via SIP Trunk

I have CME 8.6 running on a 2801 router. There are two 9971 phones (SIP only) registered as well as two analog phones connected via a dual-port FXS card. I have a SIP trunk between the CME and CUCM at the main office. I can 4-digit dial between these 4 phones fine. Additionally, the analog phones can 4-digit dial to phones at the main office as well as make and receive external calls, so that tells me that my dial-peers are configured properly.

The 9971 phones, on the other hand, simply respond with a fast-busy when you try to call out. When you call via DID to one, it rings, but then when you pick it up there is a fast-busy.

Here are some configuration snippets:

voice service voip
 ip address trusted list
  ipv4 10.152.111.128 255.255.255.248
 allow-connections sip to sip
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  registrar server expires max 3600 min 120
voice class codec 1
 codec preference 1 g711ulaw
voice class cause-code 1
no-circuit
voice register global
mode cme
source-address 10.11.20.227 port 5060
max-dn 48
max-pool 24
load 9971 sip9971.9-1-1SR1
authenticate register
authenticate realm all
timezone 8
tftp-path flash:
logo Desktops/640x480x24/gaming32.png
file text
create profile sync 0512702122126068

Perhaps there is more info that would be relevant, but for the moment that's what I'll paste in. Please let me know if you have thoughts.

1 ACCEPTED SOLUTION

Accepted Solutions
Mohammed al Baqari
VIP Advisor

Did you assign g711ulaw codec under your 9971 voice register pool (or the
voice class). If you leave it blank, it will use g729.

If all this is good, as requested get the debugs

View solution in original post

4 REPLIES 4
Gregory Brunn
Collaborator

Please post rest of the config.

Also please capture debug ccsip messages and attach. 

Mohammed al Baqari
VIP Advisor

Did you assign g711ulaw codec under your 9971 voice register pool (or the
voice class). If you leave it blank, it will use g729.

If all this is good, as requested get the debugs

View solution in original post

This was my thought as well Mohammad. I wanted to rule out a codec issue. We should be easily able to see that in the SIP SDP message exchange.

That fixed it! Thank you my friend. Here's what I did, as per your suggestion, and voila!

voice register pool 1
  codec g711ulaw
voice register pool 2
  codec g711ulaw

Matt

 

Content for Community-Ad

Spotlight Awards 2021