cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5565
Views
0
Helpful
7
Replies
Highlighted
Beginner

CME Caller id problem on SIP trunk to trunk forwarded calls

Hi

I am having a bit trouble to get this changed.

Call flow

A party - 67777777 (External Caller)

B party - 98888888 (SIP DDI configured on UC540)

C Party - 00198761234 (External number which call need to be forwarded to)

SIP DDI 98888888 will ring on one of desk phone extension 201. When C party receive a forwared call from B party.

It always shows the origianl caller's phone number (A party number) instead SIP DDI 98888888.

I check CME configuraiton.

under SIP-UA no remote-party-id has been configured.

under voice service voip -> SIP -> no update-callerid is configured as well.

Is there any other settings which I can disable this feature. Forward origianl caller-id to external when Cisco CME divert incoming call to another external destination?

Many Thanks

Kevin

7 REPLIES 7
Highlighted
Beginner

Can you share you configuration, especially your dial peers?

Sent from Cisco Technical Support iPad App

Highlighted
Hall of Fame Master

That is normal and is often asked had you searched before asking.. Your SIP provider does not allow you to originate calls with any number execept yoru own. Otherwise you would be spoofing caller-id.

Highlighted

I believe the O.P. is stating that the opposite is happening, ie. he wants the caller id to show as the sip trunk did rather than the original caller??

Sent from Cisco Technical Support iPad App

Highlighted

Interesting. You can then ignore my comment.

Highlighted

This is common with sip providers. They allow you to present the original caller id as long as you can authenticate using your diversion header...

I am not sure how you can change this behaviour with CCME as you do with CUCM. I will look around

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts
Highlighted

Also check if you have disabled the REFER and MOVED TEMPORARILY supplimentary services. Disabling these will cause the router to hairpin the call which should present the SIP trunk DID rather than the original caller ID. This is completed under using the following.

Globally

voice service voip

sip

   no supplementary-service sip moved-temporarily

   no supplementary-service sip refer

OR on the SIP provider dial peers

dial-peer voice xxx voip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

Highlighted

Hi

To daniel.bloom

Thanks for your suggestion.

Yes. I have these two Commands loaded.

sip

   no supplementary-service sip moved-temporarily

   no supplementary-service sip refer

System was programmed through CCA. so most of those commands loaded already. I just couldn't find there is any setting in CCA which I can change to disable forwarding origianl A party when a call is forward through CME.

To Paolo Bevilacqua

Yes. The reason I am doing that is ISP blocked calls if original A party is forward to them. so I have to change it.

and yes. I have searched this issue online for I but didn't find muich useful info. Most of discussions for this issues are about CUCM. not CME.

Anyway. Thanks for everyone's help at here. I fixed this via modified default Translation rules for outbound calls.(through CLI).  Doesn't seem be able to do anything through CCA for that kind of issue.

Content for Community-Ad