cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5885
Views
9
Helpful
9
Replies

Configure 7965 with SIP

lostinvoip
Beginner
Beginner

Hello. I'm about to setup a VoIP in a lab environment using SIP. And I've a few wonderings about how to tackle this.

The equipment I've are the following:

-Two Cisco 2811 Routers with a few integrated modules such as HWIC-4ESW-POE

-Two Cisco IP Phone 7965 (never been used)

-Computers

The router has ios c2800nm-spservicesk9-mz.150-1.M4.bin, and has never been used.

Now I've got CME 8.6 in my USB flash, which contains

-cmterm-7945_7965-sip.9-1-1SR1.tar

-a folder called CME8.6.0GUI

-....

I assume I've to setup the phones with the firmware and install the CME in the router in some way.

How do I do this?

Thanks in advance.

1 Accepted Solution

Accepted Solutions

Under telephony-service, configure ip source with the address of the voice vlan.

Under there also go a bunch of other useful commands.

Recommend you configure spanning-tree portfast under the interfaces for phones.

View solution in original post

9 Replies 9

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Have you (even remotely) considered searching the forum before asking questions that have been answered manny, many times ?

Of course I've searched, but I've not found what I'm looking for. Let me break down and clarify my question.

-The CME 8.6 gui folder contains these files: http://img233.imageshack.us/i/cme860gui.jpg/

-The cmterm-7945_7965-sip.9-1-1SR1.tar contains these files: http://imageshack.us/photo/my-images/861/cmterm79457965sip911sr1.jpg/

1. Which files from the sip.tar do I need to send to the 7965 phone in order to get it up?

2. If I don't want to use the GUI for CME configuration, do I still have to upload these GUI-files to the intended router in order to get CME 8.6 working?

3. How come I don't have such a file* in my CME 8.6-folder?

*P0xxxxxxxxxx.bin http://www.ciscopress.com/articles/article.asp?p=1182471

You cannot use CME 8.6, because that requires a newer IOS image that you don't have.

Also, leave phones as SCCP, that is the only true CME product. Phone as SIP have less features and more bugs.

Thank you Paulo for your answer. The IOS is now updated to a compatible one to cme 8.6. SIP may be "buggy" but i need to use it because of instructions I've got.

Now I've tried to upgrade firmware to phone plugged in to 0/2/0 which goes up and down:

*May 25 10:52:15.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
*May 25 10:52:15.179: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
*May 25 10:52:20.347: %LINK-3-UPDOWN: Interface FastEthernet0/2/0, changed state to up
*May 25 10:52:21.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2/0, changed state to up
*May 25 10:52:49.351: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
*May 25 10:52:49.351: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

The phone is starting with the first "upgrading-screen" then switches over to the cisco-start-screen and never goes longer than that, just repeating. DHCP is working; the phone can be pinged from the cme router with success on ip add 172.16.1.2. So dhcp is working:

Router#show ip dhcp bin
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
172.16.1.2          01ec.c882.b1cc.89       May 26 2011 11:55 AM    Automatic

I think the phone cannot connect to the tftp-server on the cme router. #debup tftp events gives no output. What's wrong?

Router#show run
Building configuration...

Current configuration : 2822 bytes
!
! Last configuration change at 11:36:59 zone Wed May 25 2011
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 1/0
!
no aaa new-model
!
clock timezone zone 1 0
no network-clock-participate slot 1
no network-clock-participate aim 1
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip dhcp pool VOICE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 66 ip 172.16.1.1
!
ip dhcp pool DATA
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
allow-connections sip to sip
sip
  registrar server expires max 600 min 60
!
!
voice register global
mode cme
source-address 172.16.1.1 port 5060
max-dn 10
max-pool 4
load 7965 SIP45.9-1-1SR1S
file text
create profile sync 0004277415148052
!
voice register dn  1
number 1001
shared-line
!
voice register pool  1
id mac ECC8.82B1.CC89
type 7965
number 1 dn 1
!
!
!
!
voice-card 0
!
voice-card 1
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FCZ1447701P
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/2/0
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface FastEthernet0/2/1
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface FastEthernet0/2/2
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface FastEthernet0/2/3
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 172.16.1.1 255.255.255.0
!
interface Vlan100
ip address 172.16.2.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
tftp-server flash:/apps45.9-1-1TH1-16.sbn
tftp-server flash:/cnu45.9-1-1TH1-16.sbn
tftp-server flash:/cvm45sip.9-1-1TH1-16.sbn
tftp-server flash:/dsp45.9-1-1TH1-16.sbn
tftp-server flash:/jar45sip.9-1-1TH1-16.sbn
tftp-server flash:/SIP45.9-1-1SR1S.loads
tftp-server flash:/term45.default.loads
tftp-server flash:/term65.default.loads
!
control-plane
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
mgcp profile default
!
!
!
sip-ua
retry register 10
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
ntp server 172.16.10.1
end

Check with "debug tftp events" what is happening. Also possible you would need to update to an intermediate version depending what the phones have now.

Tell the person that gave you instructions, that cisco phones in SIp with CME, is a bad idea.

We listened to your advise and gave up SIP for SCCP. The upgrade of firmware went out well, no problem.But now my phones cannot register to the CME insted.

Router#show ephone registered

No ephone in specified type/condition.

The following tftp events occure over and over:

*May 31 11:56:41.623: TFTP: Looking for CTLSEPECC882B1C358.tlv

*May 31 11:56:41.695: TFTP: Looking for ITLSEPECC882B1C358.tlv
*May 31 11:56:41.771: TFTP: Looking for ITLFile.tlv
*May 31 11:56:41.927: TFTP: Looking for SEPECC882B1C358.cnf.xml
*May 31 11:56:41.927: TFTP: Opened system:/its/vrf1/XMLDefault7965.cnf.xml, fd 10, size 0 for process 149
*May 31 11:56:41.931: TFTP: Finished system:/its/vrf1/XMLDefault7965.cnf.xml, time 00:00:00 for process 149

And the phones shows registering all the time.

Are the ephoneconfiguration wrong? I don't think so.

Router#show run | sec ephone
max-ephones 4
ephone-dn  1
number 1001
name Phone One
ephone-dn  2
number 1002
name Phone Two
ephone  1
device-security-mode none
mac-address ECC8.82B1.CC89
type 7965
button  1:1
ephone  2
device-security-mode none
mac-address ECC8.82B1.C358
type 7965
button  1:2

What can i do to fix this?

Message was edited by: lostinvoip

You may be need to do "license accept end-user eula" or something like thayt.

Would need to see the full telephony-service. You can also do debug ephone registration.

Thank you again Paolo for your answer.

debug ephone register gives no output. What conclusion can we draw from that?

run config:

Current configuration : 2862 bytes
!
! Last configuration change at 12:16:55 sthlm Tue May 31 2011
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 1/0
!
no aaa new-model
!
clock timezone sthlm 1 0
no network-clock-participate slot 1
no network-clock-participate aim 1
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 172.16.1.1
ip dhcp excluded-address 172.16.2.1
!
ip dhcp pool VOICE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 150 ip 172.16.1.1
!
ip dhcp pool DATA
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
!
!
!
!
!
voice-card 0
!
voice-card 1
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FCZ1447701P
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/2/0
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface FastEthernet0/2/1
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface FastEthernet0/2/2
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface FastEthernet0/2/3
switchport access vlan 100
switchport voice vlan 10
no ip address
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 172.16.1.1 255.255.255.0
!
interface Vlan100
ip address 172.16.2.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
tftp-server apps45.9-1-1TH1-16.sbn
tftp-server cnu45.9-1-1TH1-16.sbn
tftp-server cvm45sccp.9-1-1TH1-16.sbn
tftp-server dsp45.9-1-1TH1-16.sbn
tftp-server jar45sccp.9-1-1TH1-16.sbn
tftp-server SCCP45.9-1-1SR1S.loads
tftp-server term45.default.loads
tftp-server term65.default.loads
!
control-plane
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
mgcp profile default
!
!
!
!
!
telephony-service
max-ephones 4
max-dn 4
load 7965 SCCP45.9-1-1SR1S.loads
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn  1
number 1001
name Phone One
!
!
ephone-dn  2
number 1002
name Phone Two
!
!
ephone  1
device-security-mode none
mac-address ECC8.82B1.CC89
type 7965
button  1:1
!
!
!
ephone  2
device-security-mode none
mac-address ECC8.82B1.C358
type 7965
button  1:2
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
ntp server 10.1.2.3
end

The phone status messages shows:

-error verifying config info

-sepecc882b1cc89.cnt.xml

-no trust list installed

-no ipv4 dns server

Under telephony-service, configure ip source with the address of the voice vlan.

Under there also go a bunch of other useful commands.

Recommend you configure spanning-tree portfast under the interfaces for phones.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers