cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1487
Views
0
Helpful
2
Replies
jmartin
Beginner

Configuring Incoming Calls to route to internal extension

I have a Cisco 2921 Router that has a 4 FXO card in it. I would like to configure it so that ALL incoming calls on all 4 ports to be fowarded to a internal extension (1001), this is for a test environment and I can't seem to figure out what I am missing. The config is below:

Building configuration...

Current configuration : 8500 bytes

!

! Last configuration change at 08:19:46 EST Fri Mar 1 2013 by jmartin

!

version 15.1

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

no service password-encryption

service sequence-numbers

!

hostname WH-VOIP-2900

!

boot-start-marker

boot-end-marker

!

!

logging buffered 10000000

!

aaa new-model

!

!

aaa authentication login default group tacacs+ local line

aaa authentication login NOAUTH none

aaa authorization exec default group tacacs+ local none

aaa authorization exec NOAUTH none

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting connection default start-stop group tacacs+

!

!

!

!

!

aaa session-id common

!

clock timezone EST -5 0

clock summer-time EST recurring

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

ip domain name mgsd.edu

!

multilink bundle-name authenticated

!

!

!

!

!

!

trunk group FXO

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-3979560690

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3979560690

revocation-check none

!

!

crypto pki certificate chain TP-self-signed-3979560690

certificate self-signed 01

  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33393739 35363036 3930301E 170D3130 31323232 31333533

  30375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39373935

  36303639 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100DD47 9227149F 2D084CE5 3D227595 7DBF4FCA C3519000 3F468821 D56F653A

  E74FCBAD B4936598 F0C26B2B 6132ADE7 1B1BDC89 44D3C53F 63DDAF78 8E08FCA7

  7044095A DBE38889 7CD48871 94ED1CF9 F2ECC50A 8BD21AFC 5BC3B3FC B322E161

  F3CE339A 88AA803B E3705349 03A7D918 C11E5844 ECF039EB FEC44CDF 52A59AE5

  0C430203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603

  551D1104 19301782 1557482D 564F4950 2D323930 302E6D67 73642E65 6475301F

  0603551D 23041830 16801463 9BA90049 2F6005DC F2A35FC3 329D4138 0EDB2530

  1D060355 1D0E0416 0414639B A900492F 6005DCF2 A35FC332 9D41380E DB25300D

  06092A86 4886F70D 01010405 00038181 005C2C45 9F687AEF 3219F567 337E55CD

  9E524A1B 7879B3B1 F3C872F9 DFF7F014 FFE0D84B 67252EFE 3DFF8959 9565ADE2

  79857E34 FFF2C3DE 667D5D62 8A4E4690 D874CF4A 8B180832 7748D1E8 BB71543B

  BC404126 02DABACB DDF24EE6 6F63F8CE F7F8494C 66115C77 B768BC77 DA2D5C2C

  984DC376 A16F2B81 D1CBD44F F23B8605 D4

            quit

voice-card 0

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

voice class h323 1

  h225 timeout tcp establish 3

  call start slow

  call preserve

!

!

!

!

!

license udi pid CISCO2921/K9 sn FTX1448AJ6B

hw-module pvdm 0/0

!        

!

!

username admin privilege 15 secret 5 $1$iKc/$uQJli0iQG9VAu4PiFeYC8/

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

description to Inside LAN

ip address 10.40.0.51 255.255.0.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.40.0.51

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 10.40.0.1

!

!

!

!

!

!

snmp-server community mgsdvoip RO

snmp-server community mhsswitch RO

snmp-server location "Mooresville High School"

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps eigrp

snmp-server enable traps envmon fan shutdown supply temperature status

snmp-server enable traps flash insertion removal

snmp-server enable traps energywise

snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-change inconsistency

snmp-server enable traps config-copy

snmp-server enable traps config

snmp-server enable traps config-ctid

snmp-server enable traps entity

snmp-server enable traps hsrp

snmp-server enable traps cpu threshold

snmp-server enable traps syslog

snmp-server enable traps vtp

snmp-server enable traps srst

snmp-server enable traps voice

snmp-server host 10.65.0.252 version 2c mgsdvoip

snmp-server host 10.10.0.252 version 2c mhsswitch

tacacs-server host 10.60.253.10 key Pa$$word

tacacs-server directed-request

!

!

control-plane

!        

!

voice-port 0/0/0

trunk-group FXO 1

connection plar 1001

description 704-799-0516

!

voice-port 0/0/1

trunk-group FXO 2

connection plar 1001

!

voice-port 0/0/2

trunk-group FXO 3

connection plar 1001

!

voice-port 0/0/3

trunk-group FXO 4

connection plar 1001

description ==> To 911

!

!

!

sccp local GigabitEthernet0/0

sccp ccm 10.65.0.63 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate profile 1 register WH-2900_CFB

associate profile 2 register WH-2900_MTP

!

dspfarm profile 1 conference 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dspfarm profile 2 mtp 

codec g711ulaw

maximum sessions hardware 2

associate application SCCP

!

dial-peer voice 1 pots

trunkgroup FXO

incoming called-number .

!

dial-peer voice 2 pots

destination-pattern 9[2-9]11

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

port 0/0/3

forward-digits 3

!

dial-peer voice 3 pots

destination-pattern 911$

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

port 0/0/3

forward-digits all

!

dial-peer voice 4 pots

trunkgroup FXO

destination-pattern 9[2-9]..[2-9]......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

forward-digits 10

!

dial-peer voice 5 pots

trunkgroup FXO

destination-pattern 91[2-9]..[2-9]......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

forward-digits 11

!

dial-peer voice 6 pots

trunkgroup FXO

destination-pattern 9011T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

prefix 011

!

dial-peer voice 32 pots

trunkgroup FXO

description SRST 4-digit dialing to other sites

destination-pattern 2...

forward-digits all

prefix 704658

!

dial-peer voice 100 voip

preference 1

destination-pattern [2]...

progress_ind setup enable 3

progress_ind connect enable 8

progress_ind disconnect enable 8

session target ipv4:10.65.0.23

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

fax rate 14400

ip qos dscp cs5 signaling

no vad

!

dial-peer voice 101 voip

preference 2

destination-pattern [2]...

progress_ind setup enable 3

progress_ind connect enable 8

progress_ind disconnect enable 8

session target ipv4:10.65.0.63

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

fax rate 14400

ip qos dscp cs5 signaling

no vad

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 4 gain -6

transfer-system full-consult

timeouts interdigit 3

ip source-address 10.40.0.51 port 2000

max-ephones 50

max-dn 100 dual-line

system message primary Phone is in Standalone Mode

system message secondary Standalone Mode

dialplan-pattern 1 7046582... extension-length 4

transfer-pattern .T

keepalive 10

voicemail 2525

call-park select no-auto-match

call-forward pattern .T

call-forward busy 97046582525

call-forward noan 97046582525 timeout 16

date-format dd-mm-yy

!

!

vm-integration

pattern direct *** CGN    

pattern ext-to-ext no-answer 5 FDN * CGN * 

pattern ext-to-ext busy 7 FDN * CGN * 

pattern trunk-to-ext no-answer 4 FDN * CGN * 

pattern trunk-to-ext busy 6 FDN * CGN * 

!

!

line con 0

password V01pG8te

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

password V01pG8te

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

password V01pG8te

transport input telnet ssh

line vty 16 1114

transport input all

!

scheduler allocate 20000 1000

ntp server 129.6.15.29

end

1 ACCEPTED SOLUTION

Accepted Solutions
Craig Dyer
Participant

Jeff,

     I am assuming that the voip dial peers 100 & 101 are pointing to a CuCM?

     The destination pattern on the voip dial peers doesn't match 1001 set on the PLAR and they need changing to something like:-

dial-peer voice 101 voip

     dial-peer voice 100

          destination-pattern [12]...

     dial-peer voice 101

          destination-pattern [12]...

destination-pattern [2]...

Hope this helps,

Craig

PLEASE RATE HELPFUL POSTS

View solution in original post

2 REPLIES 2

Jeff,

What happens when you m ake a test call.where does the call go?

can you send us debug vpm signal and debug voip ccapi inout

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts
Craig Dyer
Participant

Jeff,

     I am assuming that the voip dial peers 100 & 101 are pointing to a CuCM?

     The destination pattern on the voip dial peers doesn't match 1001 set on the PLAR and they need changing to something like:-

dial-peer voice 101 voip

     dial-peer voice 100

          destination-pattern [12]...

     dial-peer voice 101

          destination-pattern [12]...

destination-pattern [2]...

Hope this helps,

Craig

PLEASE RATE HELPFUL POSTS

View solution in original post

Content for Community-Ad

Spotlight Awards 2021