Showing results for 
Search instead for 
Did you mean: 

DX80 Red Ring of Death

Safely powered off my DX80 endpoint yesterday which has been working flawlessly. Went to power back on today and power button has a red light on and will not start. Tried unplugging and resetting connections but no luck. Any help would be greatly appreciated.


5 Replies 5

Level 7
Level 7


I'm sorry to hear you are having problems with your DX80. I recommend you also post this to the Cisco Support Community for more feedback and information. In addition, you can open a case with Cisco TAC ( for expert technical assistance.

Cisco Support Community

Kelli Glass

Moderator for Cisco Customer Communities

Level 1
Level 1

I've encountered the same issue. Did you ever resolve this?

Travis Shorten
Level 1
Level 1

Try unplugging so front light is off. Plug back in. Hold reset button (small hole in rear panel) and push front power button.

I work repairing Cisco products and this helped me fix a unit I was working on.

Level 1
Level 1

I had the same issue today and I freaked out!


With the whole corona thing going on (March 2020), my DX80 has become a very important tool while working from home.

After searching the internet and finding no solution, I replaced the power cord (cord only, not the brick).


Since the original cord was an EU plug, I had to use it with an extension box with EU plug compatibility.


I replaced that with a regular UK mains plug (like a monitor cable plug or what we sometimes call kettle-lead) and I connected it directly to the mains (instead of connecting to the extension box).


All working for me, so wanted to share in case someone hit the same issue and had't tried this yet.