cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
14819
Views
0
Helpful
31
Replies
kevintang
Beginner

Failed install CUCM 9.1 on VM, Can not read the dump log file.

Hi,

I failed install CUCM 9.1 on VM ESXi 4.1 server. following this link, I have got the install log file.

http://docwiki.cisco.com/wiki/How_to_Dump_Install_Logs_to_the_Serial_Port_of_the_Virtual_Machine

I have followed the instrution and attached a new, empty file to the serial port when dump the install log. but when I open the log file, all of the then are unreadable symbol.

any idea?

Regards

Kevin

6 ACCEPTED SOLUTIONS

Accepted Solutions

I've checked your install.log and I found it's the same error I had during the istallation of CUCM 9.1.1.20000-5 on VmWare ESXi 5.0.

The hardware architecture is based on HP Proliant BL460c Gen8 servers, with Intel Xeon CPU E5-2680 @ 2.70GHz, that should be supported for Cisco UC (http://docwiki.cisco.com/wiki/UC_Virtualization_Supported_Hardware) so I don't think the problem is related to some hardware incompatibility:

04/03/2013 14:26:38 IPM|For RPM command "rpm --percent -iv --replacefiles /common/rpm-archive/9.1.1.20000-5/RPMS/database/cm-dbl-1.0.0.0-1.i386.rpm ": user database does not exist - using root|<:WARN>
04/03/2013 14:26:42 IPM|      item  2: rpm-install   13132993 bytes (21.700 secs.)|<:INFO>
04/03/2013 14:26:42 IPM|Execute shell command "/usr/local/cm/script/cm-dbms-install install PostInstall 9.1.1.20000-5 9.1.1.20000-5 /usr/local/cm/ /usr/local/cm/ /common/log/install/capture.txt "|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: -bash: onmode: command not found|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: tail: cannot open `/var/log/active/cm/log/informix/ccm.log' for reading: No such file or directory|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: Changing password for user informix.|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: passwd: all authentication tokens updated successfully.|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: passwd: Unknown user name 'database'.|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture:  arg1: [IN] |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture:  arg2: [9.1.1.20000-5] |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture:  arg3: [9.1.1.20000-5] |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture:  arg4: [/common/log/install/capture.txt] |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: su -c 'if [ -f /usr/local/cm/db/informix/local/ids.env ]; then source /usr/local/cm/db/informix/local/ids.env; fi ; onmode -yck' - informix|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: input param /usr/local/cm/script/cm-dbms-install IN PO 9.1.1.20000-5 9.1.1.20000-5 /usr/local/cm/ /usr/local/cm/ /common/log/install/capture.txt|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: Log location [/common/log/install/capture.txt]|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|capture: Inside cm-dbms-install log location [/common/log/install/capture.txt]|<:DEBUG>
04/03/2013 14:26:46 IPM|capture: |<:DEBUG>
04/03/2013 14:26:46 IPM|Internal Error, File:ipm.c:2006, Function: ipmReadNormalizedInputLine(), "/usr/local/cm/script/cm-dbms-install install PostInstall 9.1.1.20000-5 9.1.1.20000-5 /usr/local/cm/ /usr/local/cm/ /common/log/install/capture.txt " failed (1)|<:CRITICAL>
04/03/2013 14:26:48 IPM|  end-of-session "Installing database component": 38.715 secs.|<:INFO>
04/03/2013 14:26:48 IPM|Close progress meter "Component Install"|<:INFO>
04/03/2013 14:26:48 component_install|(CAPTURE) SET CcmFirstNode=yes|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) SET CcmDBHost=|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install.ParamObject.validate  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install.ParamObject.validate  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install  DEBUG:  Install type|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install  DEBUG:  post phase|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install  DEBUG:  The DBMS RPM/ untar has been run, we now need to initialize the DBMS|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:41 2013 cm-dbms-install  DEBUG:  /usr/local/cm/bin/dbl init IN 9.1.1.20000-5 9.1.1.20000-5 /common/log/install/capture.txt|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:42 2013 dblinit-plugin.run  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:42 2013 dblinit-plugin.run  DEBUG:  Initialize the DBMS|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:42 2013 dblinit-plugin.run  DEBUG:  Hardware model [VMware]|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:42 2013 dblstop-plugin.run  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:42 2013 dblstop-plugin.run  DEBUG:  Stop DBMS|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblstop-plugin.run  DEBUG:  ---|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblstop-plugin.run  DEBUG:  ---|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblstop-plugin.run  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.findTarBall  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.findTarBall  DEBUG:  Found compressed /usr/local/cm/install/ids/linux-install.tar.gz|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.findTarBall  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  Inside readPlatformConfigPassword...|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:   isl2 [False]|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  Line Matched:   |<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) |<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  Line Matched:     Security PW for this node|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) |<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  Line Matched:     password|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) |<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  Line Matched:     2F6821FDB76EFD8974C17629DAFBB75D831812812AB2825C831812812AB2825C|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) |<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  ParamValue Matched: 2F6821FDB76EFD8974C17629DAFBB75D831812812AB2825C831812812AB2825C|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  2f6821fdb76e|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.readPlatformConfigPassword  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  Inside addInformixUserGroup|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  opening /etc/passwd for userid informix|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  -->|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  Inside addInformixUserGroup|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  Updating /etc/shadow...|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.run  ERROR:  ERROR: "Error executing [echo '266821642765' | passwd --stdin -f database] returned [64512]"|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.addInformixUserGroup  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 dblinit-plugin.run  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 cm-dbms-install  ERROR:  Install Post Failed|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 cm-dbms-install  DEBUG:  >>> cm-dbms-install [1]|<:DEBUG>
04/03/2013 14:26:48 component_install|(CAPTURE) Wed Apr  3 14:26:43 2013 cm-dbms-install  DEBUG:  <--|<:DEBUG>
04/03/2013 14:26:48 component_install|File:/opt/cisco/install/bin/component_install:743, Function: exec_progmeter(), /opt/cisco/install/bin/progmeter failed (1)|<:ERROR>
04/03/2013 14:26:48 appmanager.sh|Internal Error, File:/usr/local/bin/base_scripts/appmanager.sh:147, Function: install(), failed to install infrastructure_post components|<:CRITICAL>
04/03/2013 14:26:48 post_install|File:/opt/cisco/install/bin/post_install:911, Function: install_applications(), /usr/local/bin/base_scripts/appmanager.sh -install failed (1)|<:ERROR>
04/03/2013 14:26:48 post_install|Exiting with result 1|<:INFO>
04/03/2013 14:26:48 post_install|INSTALL_TYPE="Basic Install"|<:DEBUG>
04/03/2013 14:26:48 post_install|File:/opt/cisco/install/bin/post_install:619, Function: check_for_critical_error(), check_for_critical_error, found /common/log/install/critical.log, exiting|<:ERROR>
04/03/2013 14:26:48 post_install|(CAPTURE) Mail notification cancelled - smtp server address for email not found! [/usr/local/platform/conf/platformConfig.xml]|<:DEBUG>
04/03/2013 14:26:48 display_screen|Arguments: "Critical Error" "The installation has encountered a unrecoverable internal error. For further assistance report the following information to your support provider.

"/usr/local/cm/script/cm-dbms-install install PostInstall 9.1.1.20000-5 9.1.1.20000-5 /usr/local/cm/ /usr/local/cm/ /common/log/install/capture.txt " failed (1)

The system will now halt.

Please let me know if you get some answer from Cisco support.

Regards,

Gianmaria                  

View solution in original post

bas_076_123
Beginner

I also have the problem with ESXI 5.0.0 when tried to upgrade ver. 9.0 to 9.1. It failed. I also interested in solution and some kind of help from Cisco.

View solution in original post

I had a similar issue while I was installing CUCM9.1.1 2000-5 on ESXI5.0 in my lab. I was using an old Dell power edge 1950 server with "2 x Intel Dual Core Xeon 3.0 Ghz (5160)"

The only way I got around it after trying several times was to install CUCM8.6.2 and I then did an upgrade to 9.1.1.2000-5

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

View solution in original post

This issue seems related to CUCM version 9.1.1.20000-5, rather than an hardware incompatibility.

Installation of CUCM 9.1.1.10000-11  was successful on the same hardware, but I'm installing a subscriber and I need the same version of the publisher (that was upgraded from 8.6.2 without any problem two days ago...but it's on a physical server).

View solution in original post

Just tried the installation on Vmware ESX 4.0 on HP Proliant BL460c G1 (Intel Xeon E5345 @2.33GHz) and got the same exact error.

Definitively a problem on CUCM 9.1.1.20000-5 version, not an hardware incompatibility (although Cisco doesn't certify UC on this architecture).

I found that if you go with 9.1.1.10000-11 installation and choose to apply an upgrade patch (9.1.1.20000-5) as part of the installation, you get the same critical error, but once the machine is booted again the patch seems to be installed correctly.

I'm not sure about the reliability of this machine, but the database replicates correctly with the publisher and all the services start properly.

I'm hopeful!

View solution in original post

A quick update on CUCM 9.1.1.20000-5 installation issue.

I got a different ISO of the installation DVD from Cisco eDelivery Program (Bootable_UCSInstall_UCOS_9.1.1.20000-5.sgn.iso), that should be the bootable version of the standard ISO downloadable from Cisco website (UCSInstall_UCOS_9.1.1.20000-5.sgn.iso) and the setup was completed successfully.

It worked on two different VmWare architectures, so it's certainly a problem with the downloadable ISO.

I hope it can help you.

Regards

Gianmaria

View solution in original post

31 REPLIES 31

Kevin,

Dont even waste your time trying to read those logs. You cant. I believe its only TAC that can read them..I tried before and I learnt my lessons

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

Hi, aokanlawon

Thank you very much for sharing your experience. Hope some Cisco TAC people can show their power here before I open a TAC case.

Regards

Kevin

Hi Kevin,

I had the same problem reading the dumped log: you must attach the VM serial to a new file just before dumping the logs, otherwise you will get some extra character in the file header and you cannot open it anymore.

Here in attach your logs (already extracted with 7z).

Unfortunately I cannot help you for the installation problem: I had the same issue during CUCM 9.1.1.20000-5 installation and I0m still waiting for a solution from Cisco TAC.

It could be an hardware incompatibility, but strangely I had no problem installing version 9.1.1.10000-11 on the same hardware.

Bye.

 

Gianmaria