cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3090
Views
0
Helpful
36
Replies

ITSP-SIP-CUBE-SIP-CUCM

ashraf1891
Level 1
Level 1

Inbound call not connecting:

calling number 559903358

called number +966114817200 (translated to 7200)

________________________________________

below is my dial peers:

dial-peer voice 3 voip
description LOCAL-CALLS-1
translation-profile outgoing OUT
destination-pattern .T
session protocol sipv2
session target dns:fmc.stc.com.sa
session transport udp
voice-class codec 1
voice-class sip early-offer forced
voice-class sip bind control source-interface GigabitEthernet0/1
voice-class sip bind media source-interface GigabitEthernet0/1
dtmf-relay rtp-nte sip-notify
no vad
!
dial-peer voice 1 voip
description TO-CUCM-PUB
destination-pattern ^[1-9]...
session protocol sipv2
session target ipv4:172.30.2.10
session transport udp
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 2 voip
description TO-CUCM-SUB
preference 1
destination-pattern ^[1-9]...
session protocol sipv2
session target ipv4:172.30.2.11
session transport udp
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 4 voip
translation-profile incoming IN
session protocol sipv2
session transport udp
incoming called-number +966.T
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/1
voice-class sip bind media source-interface GigabitEthernet0/1
dtmf-relay rtp-nte sip-notify
no vad

_______________________________________
attached is  the Debug CCSIP Messages

 

36 Replies 36

From what I can tell you did not attach any file with the debug.

Apart from this I would strongly advice you to rework your dial peers as they are quite poorly written. Have a look at this great document for details on how call routing works in IOS. In Depth Explanation of Cisco IOS and IOS-XE Call Routing 

A general recommendation is to use information in the VIA header to match inbound dial peer and then you should have something that is more specific than ".T" as that matches anything and everything, and that is in general a very bad thing to do. You'd want to be a lot more specific in your match. You can also simplify your setup for outbound dial peers to CM with server group so that you'd only need one.



Response Signature


Highly Recommended to rework on the Dial-peer configurations. And no debugs are attached. If you can share complete config that would be helpful.



Response Signature


ashraf1891
Level 1
Level 1

Thanks for your replies

initially it was H323 between CUCM and CUBE the inbound was working fine but outbound was having issue that there is no ringtone to the caller then decided to change to SIP now outbound is not working it is ring once in the called party device then disconnected and nothing heard by the caller, and attached is the traces for the inbound

ashraf1891
Level 1
Level 1

Now I changed the Dial peers to be like:

dial-peer voice 3 voip
description LOCAL-CALLS-1
translation-profile outgoing OUT
destination-pattern 05........
session protocol sipv2
session target dns:fmc.stc.com.sa
session transport udp
voice-class codec 1
voice-class sip early-offer forced
voice-class sip bind control source-interface GigabitEthernet0/1
voice-class sip bind media source-interface GigabitEthernet0/1
dtmf-relay rtp-nte sip-notify
no vad
!
dial-peer voice 1 voip
description TO-CUCM-PUB
destination-pattern ^[1-9]...
session protocol sipv2
session target ipv4:172.30.2.10
session transport udp
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 2 voip
description TO-CUCM-SUB
preference 1
destination-pattern ^[1-9]...
session protocol sipv2
session target ipv4:172.30.2.11
session transport udp
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte sip-notify
!
dial-peer voice 4 voip
translation-profile incoming IN
session protocol sipv2
session transport udp
incoming called-number .
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/1
voice-class sip bind media source-interface GigabitEthernet0/1
dtmf-relay rtp-nte sip-notify
no vad

and attached is the output for inbound calls after change

You’re missing a dial peer to be used for the inbound direction from CM, for this use information in the VIA header to make the match and again please rework your inbound dial peer from the SP, ie dp 4, to use information in the VIA header to make a match instead of incoming called-number.



Response Signature


In your debug we see that you send repeated invites to what I presume is CM, but you never get any response back and then eventually you send a 408 Request Timeout to the service provider. This is likely caused by CM not recognising the traffic and then it simply ignores the communication. Have you created a SIP trunk in CM with the IP address of the interface of the gateway that faces inwards to the CM?



Response Signature


Yes, SIP trunk is created already in the CUCM with the LAN interface of the router

 

Not that I don’t trust you, but can you please share a screenshot of the trunk configuration from CM and the interface configuration in the gateway?



Response Signature


ashraf1891
Level 1
Level 1

please check the attached

Looks okay to me, but still your CM is not responding to the SIP dialogue. Would you be able to share the entire configuration from the gateway?

One recommendation not related to your issue as such, you should change the DTMF method on the SIP trunk in CM from rfc2833 to No Preference as that’s the recommended setting by Cisco.



Response Signature


ashraf1891
Level 1
Level 1

Thanks for you all

the issue was from the ITSP, they were sending the invite message to the username given for the link not the number from SIP range, outbound now is working fine, will wait for them to fix the inbound and will update again

thanks for the dial peer tips it really helped 

Hi Ashraf,

Can you tell me how you figured that they were sending the invite messages to the username and not the sip range? I am also facing the issue from new STC SIP line, the sip server is pingable and  they are just saying its issue from our end and they are not receiving any messages from our gateway. If you don't mind, can you share the complete show run to check?

Hi @kashif2401 

 

Please enable sip-options ping on the dial-peer facing STC.

You can either just enable the command "voice-class sip options-keepalive" on the dial-peer and it will use the default settings. If you need to customize the timers, you can either do it on the dial-peer or you can configure it via a keepalive profile applied to the dial-peer.

Defaults:

dial-peer voice 100 voip
 voice-class sip options-keepalive

 On dial-peer with different timers:

dial-peer voice 1000 voip
voice-class sip options-keepalive up-interval 30

Keepalive Profile and Dial-Peer (assuming a default transport of UDP):

voice class sip-options-keepalive 1000
   description STC Keepalives
   down-interval 30
   up-interval 60
   retry 5

dial-peer voice 1000 voip
  voice-class sip options-keepalive profile 1000

 

Hi @Scott Leport ,

Thanks for your suggestion, the issue has been resolved now, there was no mis-config from my side,the provider had issues with their activation.