Showing results for 
Search instead for 
Did you mean: 

Erick Bergquist
Frequent Contributor

MCS 7816-I4 server hard drive firmware issue

This is a older issue, but the following cisco documents are locked (no more comments on the support forum doc) and no feedback option on the FN.

Field Notice link:

The links to the 3.01 fw update CD in the above documents are bad now, since that update file doesn't exist at the location in the documents anymore.

I have a client with 7816-I4s with problem part # 74-6298-03 with no Deviation label on them. One of them had read-only issue and a reboot fixed it, but I am just trying to confirm the firmware levels are at the fixed level. I know the read-only file system can happen for other reasons also.

The current FW update CD is 3.6.6, FW CD 3.01 was ran on this awhile back also. The problem is I can't find what the current firmware version is anywhere on the system. The FW Update CD always saids there is a update available for the hard drive even when it just ran and upgraded. The FW Update tool saids it has version 02.0 all the time. I rebooted and re-ran the FW Update CD and it always saids there is a update recommended for the hard drive firmware on all the 7816-I4 servers.

The utils create report hardware system output shows this in the report after the firmware was upgraded,

SCSI Devices


| Manufacturer       |Product Name                 |Device Type

         |Serial Number                |Revision           |Host

Adapter ID      |Target ID            |Bus          |Lun        |


| ATA                |WD2502ABYS-23B7A             |Direct Access

Device         |                             |02.0               |0

'show hardware' doesn't report hard drive fw version numbers for 7816-I4, unlike some other models.

I went into BIOS System Information screen like FN and other documents cover but that screen doesn't report firmware version

either. No where in BIOS does it report it or boot up screens from watching the boot process a few times. So those docs seem to be not be


I even did the diagnostics in the FW Update CDs and those report 02.0

as version and not the new version.

Thanks for any input,


Rob Huffman
Hall of Fame Community Legend

Hi Erick,

My take on this is that you would have needed FWUCD 3.6(3) as a minimum to fix this issue.

This is shown in the 3.6(6) Readme - (resolved caveats chart)



"Show a little faith, there's magic in the night" - Springsteen


Right. I ran the 3.6.6 FW update CD and it updated it and said successful update but it still shows version 02.0 after power off/reboot and when you run the 3.6.6 FW Update CD again it recommends the same FW update as it still see's it as 02.0.

So thats why I posted this since comments on the document I linked to seem to be closed and I can't reply. I'm actually talking with Ryan about this who wrote the document and looks like we need to engage TAC and they will engage IBM.

Rob Huffman
Hall of Fame Community Legend

Hi Erick, bad! I didn't get that you had run 3.6.6 already (DOH!) Best of luck

with the TAC case. We ran into a similar issue with the FWCUD's and 7845H2's

recently and they ended up just replacing the drive



"Show a little faith, there's magic in the night" - Springsteen

Yea, I hear you. This client has 5 7816-I4s all with the "at risk" model number and no deviation label and one of my team members ran the 3.01 FW CD awhile back on one server that had issue and another one had issue yesterday so I went out to take closer look and do all the servers to get the issue behind us and went to go see what the FW version was, etc after the fact and couldn't find it anywhere. So then I re-ran the FW Update CD thinking it wouldn't recommend a update if it is updated and it's saying it needs updated and still shows 02.0 when it just was upgraded. LOL.

I'm hoping this doesn't come down to replacing all the drives in all the servers. I wonder if it would show the right version on new drives even... hmm.  There are no problems now with their stuff since rebooting the one server yesterday morning. I'm just trying to make sure this firmware issue isn't a possibility. I know the file system can go read-only for other reasons besides this (slow response time, improper shutdown maybe, power loss, etc).


Erick Bergquist
Frequent Contributor

Mystery solved.

The 3.6.6 FW CD update detects the firmware version wrong. I used the 3.01 update cd and it said it was already up to date and showed the current version, 02.03B07.

Recognize Your Peers
Content for Community-Ad