cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
403
Views
0
Helpful
11
Replies
Highlighted
Beginner

MOH doest not works

Hello,

   I have a simple setup with one core 3560 switch with 2 vlans Data 192.168.100.x and Voice 192.168.200.x and CME 4.1 installed on a  router 2801 with an IP address 172.16.0.1 connected to it. My phones are registering well and I am able to call. When I am trying to implement MOH it doesnt works here are the commands which I Have used

telephony-service

moh music-on-hold.au

multicast moh 239.23.4.10 port 2000

your help will be appreciated

11 REPLIES 11
Highlighted
Beginner

is is so tough question ??

Highlighted
Hall of Fame Master

Do you have multicast enabled on your switch and the voice vlan since it is different network from CME?
Do you have the moh source in flash?

Sent from Cisco Technical Support iPhone App

Highlighted

Hello Chris,

      I havent enabled the Muticast on my switch and the voice vlan. How do I do that ? Do I have to do it on the router  as well.. Yes I have the files in flash..

Highlighted
Advocate

Hi Syed

Can you find the below?. I hope to check if the audio file on the flash.

ip multicast-routing

ccm-manager music-on-hold

CME(config)# telephony-service

CME(config-telephony)#no moh "music-on-hold.au"

CME(config-telephony)# moh flash:music-on-hold.au

CME(config-telephony)# no create cnf-files

CME(config-telephony)#create cnf-files

also find the following URL:-

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmemoh.html#wp1010372

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/feature/guide/MoH.pdf

Thank you

please rate all useful infomation

Highlighted
Beginner

Thanks Islam,

         I have the file in the flash. Do I have to enable multicast on the router and switch both ?

Highlighted

Yes, if the router is on different vlan than the phones that need to get the multicast moh stream you require multicast routing between the vlans.

Chris

Highlighted
Beginner

Hello

Try to add ip pum sparse dense mode on the interface going to the switch

Sent from Cisco Technical Support iPhone App

Highlighted

Please see my router configuration and switch configuration. I have done all what mentioned above but still doestn works .

Highlighted

Hello,

    Help !!!!!!!!!!!

Highlighted

Hi,

try to do the following on the router:

conf t

ip multicast-routing

!

interface FastEthernet0/0

ip pim dense-mode

!

telephony-service

no multicast moh 239.1.1.10 port 16384

multicast moh 239.1.1.1 port 16384 route 172.16.0.1 172.16.0.2 192.168.200.1

On the switch you'll probably have to insert the ip pim dense-mode commands under the Vlan200 and the Gi0/2 interface as well.

G.

Highlighted

Thanks Greg . Presently I have IP base image on the switch, in order to run the pim command I will have to upgrade it to spservice IOS and do what you mentioned above and let you know.

Thanks

Content for Community-Ad