Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays
Hazel Pringle

MoH issues

MoH will not play.


I have 1 MoH server configured with multicast, the MRG and MRGL is all set. WAVs are loaded ready to go still no music playing.

Went to each phone and set the MRGL with the WAV that is needed still no sound.


Where could I have gone wrong?

Jaime Valencia
Hall of Fame Cisco Employee

Is your network multicast enabled?



if this helps, please rate

Jamie, I went back and enabled multicast on the router, the issue is the same. Yes I reset the phones.

Why would i enable network multicast if MoH is going to the phone?I did'nt set up any Ehanched conference bridges. Would the signal not be SCCP?

What else should I check?


Thanks for assistance

I went back and realized I misspoke. MoH uses either multicast or unicast for the stream of music but I still do not understand why you need to enable network multicast if the stream comes from the MOH server.


Anyone know what else i should check?

Hi Hazel Pringle,

 as you said before ... you have only one CUCM configured as a MoH Server and with a uploaded WAV file.

 Are you able to use MoH Unicast? In other words, your problem is only with MoH Multicast?



Mmorais Thanks.


I took the mutlicast off the server and reset the phones still the same issue. I am going to try to do another MOH server today and see if that works.

Excellent Hazel Pringle.


Hi Hazel,


A common mistake is that the audio file is not uploaded onto each communications manger with your cluster.  So it is possible that your phone is registered to a different a CUCM to that of where you have uploaded your file.  You can confirm this by registering a phone to the CUCM where you have already have the file uploaded to.

Hope this helps.


Sorry for the delay for all looking to help with this issue. See below


-Disabled the multi-cast and the same issues occur- only ToH will play when a call is on hold.

-Reviewed the cisco MoH checklist and have everything set.

-Also checked with RTMT and the report shows that all MoH streams are active and available.

-Tried to change the common device profile but had a reorder when a call was placed so i removed that.


If anyone has any tips on why i keep getting the Tone on Hold instead of the music please assist.

Hi Hazel Pringle,

 let's double check everything in CUCM Administration & CUCM Serviceability:

1) CUCM Admin > Media Resources > MoH Server - all the MoH are registered?

2) CUCM Admin > Media Resources > MoH Audio Source > <select all MoH Audio Source> - check the 'MoH Audio Source File Status', are they ok? 

3) CUCM Admin > Media Resources > MoH Audio File Management - all the MoH are in 'Translation Complete'  or 'In Use' in the 'File Status'?

4) CUCM Admin > Device > Phone > <select 2 Phones for test> - Insert the Cisco 'SampleAudioSource' in 'User Hold MoH Audio Source' and 'Network Hold MoH Audio Source'.

5) CUCM Serviceability > Tools > Control Center - Feature Service - restart the 'Cisco IP Voice Media Streaming App' for all CUCM.

6) Make a test


Hope this helps.


Hey Allen- I have a single-site deployment all of the audio files say in use.

Content for Community-Ad

Spotlight Awards 2021