Showing results for 
Search instead for 
Did you mean: 


No Ringtone on outbound calls


I have the following topology:

     CUCM <-----H.323------> Gateway (ISR3845) <------SIP------> ViaTalk (SIP Provider)

When I make an outbound call, I dial the phone number, and then there's just silence until the party answers the phone, at which point the call is connected, and they can both converse.  After the number is dialed, and before the person answers the phone, there is no ringtone, just dead silence.

When it was first setup, it worked fine....then, one day a few months ago (this is a lab setup to learn), the issue described above began to occur.

Thinking it's something with my SIP provider, I started running debugs to dig into the SIP messages.  I enabled:

     debug voip ccapi inout

     debug ccsip messages

Here are the messages I saw, in the order I saw them in:

     I sent an INVITE message out

     I received a "SIP/2.0 100 Trying" message

     I received a "SIP/2.0 183 Session Progress" message

     I sent an OPTIONS message

     I received a "SIP/2.0 200 OK" message

     I sent an ACK message

     I sent a "CANCEL" message

     I received a "SIP/2.0 487 Request Terminated" message

     I received a "SIP/2.0 200 OK" message

     I sent an ACK message

     I received an OPTIONS message

     I received a "SIP/2.0 200 OK" message

That said, I've referenced the call flow diagram between two SIP gateways in my CiscoPress Gateways book (Chapter 4), and it shows a "SIP/2.0 180 Ringing" message in the flow diagram, which I never see.


1) Shouldn't I be seeing a "SIP/2.0 180 Ringing" message from the SIP provider after I receive the "SIP/2.0 100 Trying" message?

2) Does the "SIP/2.0 183 Session Progress" message imply that the phone is ringing?

3) Am I on the right track?

Logically, seems like this could be the issue, but I wanted to run it by someone more knowledgable than I.  Any assistance which can be provided would be appreciated.

Thank you.



Hi Luis,

Can you post the debug output?

If the Service Provider received an alerting message then it would forward "180 Ringing" instead of 183 Session Progress. The reason why I believe that you are seeing Session Progress is because the endppints need to negotiate the RTP stream parameters.

Normally you can spoof the caller by the command "voice call send-alert" to change any progress messages to an alerting message (if you want to do it). Also enable "voip rtp send-recv" so that the caller can hear any error message that the service provider plays out.


Arun Kumar

Please rate useful posts !!


Thank you for your prompt response.

I tried the "voice call send-alert" earlie today, and there was no change.   I have not tried the "voip rtp send-recv".

Additionally, I found this posting that sounds similar to what I'm experiencing, and I am including it as a reference for you:

As requested, the debugs are attached.   In this debug, I made a call, but never answered the call, as I was just testing for the ringtone.

Thank you.


Hello to all,

I had pretty much the same problem, where there was no ringback on outbound calls.

The setup was:

local PBX<==ISDN E1 ===> CISCO GW (28xx) <==SIP==> VoIP Provider

On a gateway, i recieverd 183 Session in progress upon outbuond INVITE from provider, and there was silence, until called party picked up.

After I applied "voice call send-alert" on gateway, the ringtone started to appear.

I hope it hepls someone.

Recognize Your Peers
Content for Community-Ad