cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
9820
Views
0
Helpful
3
Replies
bfpnetworking
Beginner

Non-Cisco VOIP Phones and VLAN configuration

Hi all.  Any help and documentation would be appreciated.

We have a 172.17.x.x/16 LAN connected to a 192.168.200.X/24 subnet using an 1811 router.

Currently, we have 2960G 24 port switches.  The POE ports where VOIP phones are connected are configured with the following and have computers attached behind the VOIP phones:

interface GigabitEthernet1/0/1

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

priority-queue out

mls qos trust cos

spanning-tree portfast trunk

spanning-tree bpduguard enable

The uplink ports on 172.17.x.x are configured with the following:

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport nonegotiate

priority-queue out

mls qos trust cos


I connect our Non Cisco phones anywhere on the 172.17.x.x network and it works fine.  We have the 192.168.200.x subnet POE 2960 switch configured the same except it connects to the 172.17.x.x network through an 1811 router.  The phone will power on, display the time/date briefly, then continue "trying to connect".

The goal is to implement VOIP phones in their own VLAN (2) and have the computers continue to send their traffic on VLAN 1.  I am told by Cisco to do the above steps.  I am tolda by non Cisco tech support to do:

Switch(config)#int fa0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 1
Switch(Config-if)# switchport voice vlan 2

Who is right, and what best fits my scenario?  Any help is greatly appreciated. 

3 REPLIES 3
Brandon Svec
Contributor

The top example seems close to correct.  The bottom example will only work with Cisco phones or phones that support CDP maybe.

description VOIP/PC Port
switchport access vlan 1
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,2
switchport mode trunk

Will give you a trunk port and tag vlan 2 but leave vlan 1 as native, untagged.

Your next trick will be to get config files to the phones first on the native vlan 1 then let the phones reboot with new config file tagged on vlan 2.

-- please remember to rate and mark answered helpful posts --
barry
Rising star

Hi

The "switchport voice" command is really only designed to work with phones supporting CDP/LLDP, so predominantly this is for Cisco handsets. In my experience, It also works with Nortel handsets too.

Your VLAN trunk config looks fine and I would use this for non Cisco phones.

You don't mention what type of handsets you are trying to get working, but you need to understand how the handset registration process works to continue debugging this.


As an example, Mitel handsets by default do the following:

1. Boot in the native VLAN and attempt to find a DHCP server.

2. The DHCP server needs to return additonal options which include the voice VLAN for the phone.

3. The phone upon receiving these options reboots and starts tagging the voice VLAN on it's packets (leaving the PC attached behind it in the native VLAN).

4. It then gets a DHCP address in the voice VLAN - the DHCP server in this VLAN also needs to return the IP address of the PBX, and generally the file name of the OS image it needs to load (you may also be able to do this via the DHCP server in step 2, can't absolutely remember).

5. Phone then registers.

More than likely your issue here is related to your phone config.

It is also possible on a lot of handsets to set the voice VLAN manually rather than relying on DHCP options however I strongly recommend that you don't do this - it means a visit to every handset if you ever change anything.

A wireshark trace of the phone may also shed some light on what is happening, although you need to be careful as most Windows drivers strip off 802.1Q headers so you don't see what VLAN the packets belong to.

HTH. Barry

I know the thread is pretty old, but there are still Mitel Phones being placed in enterprises that use Cisco Switches.  I found that the new Mitel Phones support lldp and cdp.  I also found that the Mitel phones support standard Cisco VOIP phone switch configurations. 

 

switchport mode access

switchport access vlan 908

switchport voice vlan 199

spanning-tree portfast

 

The kicker is that you have to have DHCP Option 43 set for the access vlan.  The phone will book on the untagged vlan.  It needs to know its vlan.  Once it knows the vlan, it then grabs an IP from the Voice.  It passes untagged to the access vlan.  It also works with this configuration:

 

switchport mode trunk

switchport trunk native vlan 908

switchport trunk allowed vlan 199,908

spanning-tree portfast trunk

 

Since my Mitel phones use a server pre-configured.  I set my option 43 as follows only on the native or untagged vlan.  Doesn't seem to need it on the tagged one:

 

option 43 ascii id:ipphone.mitel.com;vlan=20;

Content for Community-Ad

Spotlight Awards 2021