06-13-2011 09:21 AM - edited 03-16-2019 05:25 AM
Hi
can someone please explain how the config would look like for daisy chaining a Nortel phone and pc on a cisco switch
!
ip dhcp pool Nortel-Voice-105
network 172.16.105.0 255.255.255.0
default-router 172.16.105.1
option 128 ascii "Nortel-i2004-A,213.48.250.246:5000,1,0;213.48.250.246:5000,
1,0."
option 191 ascii "VLAN-A:105."
!
interface FastEthernet0/21
switchport access vlan 79
switchport mode access
switchport voice vlan 105
speed 100
duplex full
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root
end
When the command switcport access vlan 79 , the phone stops working. the phone only works when the command switcport voice vlan 105 ALONE exists. ( i mean no switchport access vlan 79)
but we want the pcs daisy chained with the phones - so is there a way to seperate voice and data...
Thanks
06-13-2011 09:23 AM
dont need any qos config at this minute...jsut want to get this working to start with
06-13-2011 10:45 AM
Well switchport voice vlan X relies on CDP to work. I am guessing the Nortel phones support LLDP if anything. You would need a different configuration: http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_58_se/configuration/guide/swlldp.html
Switch# configure terminal
Switch(config)# network-policy 1
Switch(config-network-policy)# voice vlan 100 cos 4
Switch(config-network-policy)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# network-policy profile 1
Switch(config-if)# lldp med-tlv-select network-policy
Also be aware that Catalyst 3000 series switches will not respond to LLDP TLVs and CDP packets; only one or the other. This means you probably need to do a 'no cdp run' and reload the device after configuring LLDP.
06-13-2011 11:01 PM
Something like this should work for any IP phone not using CDP or LLDP:
interface GigabitEthernet0/45
description VOIP/PC Port
switchport trunk encapsulation dot1q
switchport trunk native vlan 79
switchport trunk allowed vlan 79,105
switchport mode trunk
You would need to get the VLAN 105 info to the phone via native VLAN dhcp or manually for this to work.
You may be able to have the native VLAN give tftp server info to the phone where it can get a config file that has proper VLAN info. Then the phone should reboot after it get's the config file, but it will boot into the voice vlan and then get voice dhcp address and start working.
Brandon
06-14-2011 02:47 AM
Thanks for your replies
just wondering something like this, will it work ?
switchport trunk encapsulation dot1q
switchport trunk native vlan 79
switchport mode trunk
switchport voice vlan 103
switchport priority extend cos 0
spanning-tree portfast
also i could enable lldp on the access switch (2960) but on 3750 looks like it i cant enable it ?
Thanks
06-14-2011 04:38 AM
got the above to work
switchport trunk encapsulation dot1q
switchport trunk native vlan 79
switchport mode trunk
switchport voice vlan 105
spanning-tree portfast
does anyone know how to apply QOS as i have only basic knowledge about VoIP. does anyone have the config and does it need applying on layer 2 and layer 3 switches?
Thanks
06-15-2011 08:51 AM
i have applied this config to nortel ip phones
int fa0/5
switchport mode trunk
switchport trunk native vla 5
switchport trunk encap dot1q
switchport voice vlan105
the ip phones seems to get an ip address in 105 range
but it doesnt seem to get ann ip address on
switcport mode trunk
switch trunk native vla1
switch trunk encap dot1q
switchport voice vlan105
Thanks
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide