07-26-2011 04:54 AM - edited 03-16-2019 06:07 AM
Hello,
I have a little problem with my UC540 (last os update ok). When I make an outgoing call, I type the prefix 0 for outgoing and make the others numbers but it take 12 to 15second to execute the call and get the first ring (in my phone outgoing planification all is ok, configured with SIP first) it's a very long delay. I make another test with 9 prefix for analogical outgoing, delay is correct it take 5-6 second to have the first ring. Someone have an idea ? Is there a configuration somewhere to change this delay ?
Regards
07-27-2011 12:21 AM
voice translation-rule 2222
!
!
voice translation-profile Atelier_Called_5
translate called 5
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile Claude_Called_9
translate called 9
!
voice translation-profile GroupeNirwana-BG_Called_4
translate called 4
!
voice translation-profile Jorge_Called_10
translate called 10
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile PSTN_CallForwarding
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile PSTN_Outgoing
translate calling 1111
translate called 1112
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile SIP_Incoming
translate called 411
!
voice translation-profile SIP_Passthrough
translate called 412
!
voice translation-profile Sebastien_Called_11
translate called 11
!
voice translation-profile Standard-AA_Called_15
translate called 15
voice translation-profile XFER_TO_VM_PROFILE
translate redirect-called 2002
!
voice translation-profile nondialable
translate called 1000
!
!
voice-card 0
!
fax interface-type fax-mail
!
!
license udi pid UC540W-FXO-K9 sn FGL152025SY
archive
log config
logging enable
logging size 600
hidekeys
username admin privilege 15 secret 5 secretcrypterpassword
username sebastien secret 5 secretcrypterpassword
!
!
ip tftp source-interface Loopback0
!
class-map match-all _class_Voice0
match ip dscp ef
class-map match-all _class_Voice1
match ip dscp cs3
!
!
policy-map Voice
class _class_Voice0
set cos 6
class _class_Voice1
set cos 3
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group EZVPN_GROUP_1
key mykey
dns 194.98.81.144
pool SDM_POOL_1
save-password
max-users 10
crypto isakmp profile sdm-ike-profile-1
match identity group EZVPN_GROUP_1
client authentication list Foxtrot_sdm_easyvpn_xauth_ml_1
isakmp authorization list Foxtrot_sdm_easyvpn_group_ml_1
client configuration address respond
virtual-template 1
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto ipsec profile SDM_Profile1
set transform-set ESP-3DES-SHA
set isakmp-profile sdm-ike-profile-1
!
!
bridge irb
!
!
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
ip virtual-reassembly in
!
interface FastEthernet0/0
description $ETH-WAN$
no ip address
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly in
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch
!
interface Dot11Radio0/5/0
no ip address
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
antenna receive right
antenna transmit right
service-policy output Voice
!
interface Virtual-Template1 type tunnel
ip unnumbered BVI1
ip nat inside
ip virtual-reassembly in
tunnel mode ipsec ipv4
tunnel protection ipsec profile SDM_Profile1
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
ip access-group 104 in
ip mtu 1452
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname myhostname
ppp chap password 7 mypassword
ppp pap sent-username myusername password 7 mypassword
ppp ipcp dns request
!
interface BVI1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface BVI100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
ip local pool SDM_POOL_1 192.168.10.50 192.168.10.60
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
If need more ask me. Thanks
07-26-2011 05:24 PM
Nobody mentioned it, but an easy way to determine if it's waiting for digit timeout is enter '#' at the end of your number. That will indicate the last digit has been entered.
Sent from Cisco Technical Support iPhone App
07-27-2011 12:13 AM
Thanks but I try with the # at the end and it's the same, it take 15 second to etablish the connection
07-27-2011 12:43 AM
Because there is no change when you add # to the end of the dialed digits, it's not the digit timeout. The issue is with the dial-peers and/or translation-profiles.
Like it was mentioned above, the pattern appears to be matching two (2) of the dial-peers.
Brian
07-27-2011 01:03 AM
Ok, but yesterday I make a cleaning in the dial-peers and I delete some unused dialpeers
I have these rules actually:
dial-peer voice 58 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*France*International Calls**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 000T
forward-digits all
no sip-register
!
dial-peer voice 62 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*France*Numero 08**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 008........
forward-digits all
no sip-register
!
dial-peer voice 66 pots
trunkgroup ALL_FXO
corlist outgoing call-national-plus
description **CCA*France*Numero Free etc**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 009........
forward-digits all
no sip-register
!
dial-peer voice 68 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*France*Value Added Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 03...
forward-digits all
no sip-register
!
dial-peer voice 69 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*France*Police (17) Fire (18) Ambulance (19)**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 01[578]
forward-digits all
no sip-register
!
dial-peer voice 70 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*France*Police (17) Fire (18) Ambulance (19)**
preference 5
destination-pattern 1[578]
forward-digits all
no sip-register
!
dial-peer voice 73 pots
trunkgroup ALL_FXO
corlist outgoing call-national-plus
description **CCA*France*Directory Enquiries**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0118...
forward-digits all
no sip-register
!
dial-peer voice 74 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*France*Network access codes**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 010..
forward-digits all
no sip-register
!
dial-peer voice 1021 voip
corlist outgoing call-international
description **CCA*France*International Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 000T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1025 voip
corlist outgoing call-national
description **CCA*France*Mobile - Fixe**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00[1-7]........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1026 voip
corlist outgoing call-toll-free
description **CCA*France*Numero 08**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 008........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1027 voip
corlist outgoing call-national
description **CCA*France*Network access codes**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 010..
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1028 voip
corlist outgoing call-national-plus
description **CCA*France*Directory Enquiries**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0118...
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1031 voip
corlist outgoing call-national-plus
description **CCA*France*Numero Free etc**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 009........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1035 voip
corlist outgoing call-emergency
description **CCA*France*Police (17) Fire (18) Ambulance (19)**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 1[578]
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1036 voip
corlist outgoing call-emergency
description **CCA*France*Police (17) Fire (18) Ambulance (19)**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 01[578]
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1037 voip
corlist outgoing call-national
description **CCA*France*Value Added Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 03...
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
07-27-2011 01:21 AM
Try building a dial-peer to "eaxctly match" a test number.
Then try dialing that number.
The dial-peer with the closest match is used.
If you still have delay in the call setup, try dropping the trunkgroup and specify an interface.
I actually suggest you manually try each interface.
--
dial-peer voice XXX pots
trunkgroup ALL_FXO
corlist outgoing FOOBAR
description SOME SPECIFIC NUMBER
preference 1
destination-pattern 0012312312345
forward-digits all
no sip-register
!
07-27-2011 02:54 AM
I make a new test with another prefix (8) and my cellphone number in the rules (i create a new rules)
like this: 8 0613133320
So the time to etablish the connection doesn't change
07-28-2011 12:49 AM
I make another test, i remove all_fxo and add only the one i use, there is no change, the delay stay the same at the start, i notice this delay append only if i use the SIP for outgoing call, it works normally when I use my analogical line
07-28-2011 12:55 AM
Hello,
Did you trace your SIP call ?
May be it's your Operator that has the delay.
Regards
07-28-2011 01:02 AM
I already call the Operator, the support take the hand on my uc540 and verify all parameters for the SIP, for them all is ok there is no problem in he SIP connection
07-28-2011 04:34 AM
Think ticket can be close, i have no solution for this, I reset completly my uc540 en reconfig it, all works fine, thanks for all to give me some solution to test
Best regards for all
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide