Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays
Alex Farah

Phone Primary Services like directories not working

Dear All

  We have faced a problem, recently we have migrated to a CUCM9 we simply import our config to the CUCM (after solving its problem), after switching to new CUCM we had  issues with some phones, hence we deleted the configuration security trust list and ITL file, after this the phones started to be registered but we lost some services like Voice mail (the button), Directories and phone designer services.

To check the problem I tested another phone which had not the same issue, I deleted the security trust list and bang the same problem appeared.

I do not understand what is the problem I tried

New Firmware and old Firmware.

I tried factory reset

Please Help!!!!


Can you go to the web interface of a working and non working phone and compare their network configurations?   I.E.

http:///CGI/Java/Serviceability?adapter=device.statistics.configuration   This should ensure that the Directories, Services etc URLs are pointed correctly.



You stated you imported your configuration to CUCM. How did you export/import the config? Have you checked to confirm your Voicemail Profile and Voicemail Pilot are configured in CUCM 9? Have you also checked under Device > Device Settings > Phone Services to confirm all of your previous services moved over correctly?

I agree with Tony, but based on your post it sounds like you do not have any phones in your CUCM 9 environment that are working as expected to compare against.


Dear Afmmaincke

    Funny, the not working Phone has the url the correct one, but the working phone does not have that!!!!?????


You need to probe the issue by using Cisco RTMT. Take the appropriate traces and check the issue

Sent from Cisco Technical Support Android App

Dear Omer

    Can you please let me know how I can probe this issue.

Best Regards

Alex Farah

Dear All

   Another issue is found, I can not go to the webpage of the problematic phones.

Dear Raymond

   Yes I used Import and Export, I can dial my VM pilot and it is working fine, I also deleted one phone and tried to re-configure it from the base no changes.

Sorry my bad, the web was disabled but still the same issue.

Best Regards

Alex Farah

Dear All

   I solved the problem, in the phone services, in the secure URL there was a "NULL"  the rest was ok, I just remove this word, saved the setting and updated the subscribsion and voila problem is fixed.

Best Regards

and thank you for sharing your thoughts

Content for Community-Ad

Spotlight Awards 2021