cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
795
Views
0
Helpful
5
Replies

"Resource unavailable, unspecified" for PSTN inbound

learner2008
Beginner
Beginner

This is a new VoIP site at Manila. The issue occured intermittenly from the day one then became hard down in two weeks. The symptom is that local users get busytone upon answering PSTN calls. I have been worked with at least three TAC Engineers and we have tried IOS upgrade, enable MTP on UCM, hard code the G711ulaw for UCM dialpeers. It was deemed working fine during test while I was on the phone with last TAC. However it broke again on the second day. It is extremy frustrating since it has been on and off for five weeks and no one has any clues why it happens. Hope someone here is able to provide help. Thanks.

The debug for isdn q931, ccapi inout, h225 asn1 and h245 asn2 is attached.

Here is the symptom in details for this test call - the call rang the IP phone 465-9120 and as soon as i answered it, the busytone kicked in and at same time, there a second call coming in and ringing same IP phone. I hanged up the first call to answer the second call then got busytone as well.

Regards,

Jessica Wang

5 Replies 5

Hi,

From the logs I can see that you are using "fast start" on your h323 gateway...With fast start here is the media negotiation process

1. Gateway sends OLC in setup

2. Gateway then sends setup--h225

3. CUCM sends its own OLC in the connect phase

4. At this point RTP flow between gateway and endpoint

5. TCS is then performed by both devices as normal...

From your trace...Here are  the obvious things

1. Gateway sends OLC in setup..it wants to do fast start

2. CUCM does not send OLC in Connect and does not send OLC at all

3. CUCM disconnects the call (disconnect is on callid=337  which is the CUCM leg)

My suggestions:

1. Turn off fast start on the gateway and test to see how it behaves..

2. Enable detaiul traces on cucm and take the traces. Send the CUCM traces herre so we can see whats going on on CUCM side.

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

Thanks so much for reply.

the running-config has been attached. Under voice service, the 'call start fast' is not present. Could you please advise how to disable it?

The statement below were added by one of TAC Engineer. He also tried to enable 'Fast start' on UCM side but test call failed after these changes -

  h245 tunnel disable

  h245 timeout olc 20

  h245 timeout tcs 10

Regards,

Jessica Wang

Can you try this...

Remove the this commands

h245 tunnel disable

  h245 timeout olc 20

  h245 timeout tcs 10

Add this..

voice service voip

h323

call start slow

then test again and send the traces..

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

yes, i have done the changes then did a test call. the trace - 'debug_2' has been attached for your view.

The H323 configuration looks like below after this change -

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol pass-through g711alaw

h323

  no h225 timeout keepalive

  call start slow

sip

!

Please advise.

Thanks,

Jessica Wang

the UCM trace files are attached as well. Please see 'Pub_Trace_2' and 'Sub_Trace_2'.

Thanks,

Jessica Wang

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers