10-25-2012 02:05 PM - edited 03-16-2019 01:53 PM
Hi. I have been trying for ages to send/receive fax without luck over a SIP trunk. I set the FXS interface and the dial-peer inbound and outbound for this port. I only have one phone line through a SIP trunk. Inbound/outbound phones calls are working. I set up one of the phones to ring for 5 secs and then transfer the call to the fax machine, an all-in-one canon mx320. I have been trying to sending faxes using igoogle and my smartphone; the fax picks the call and after few minutes ends the call. Same if I send out a fax. The receiving machine picks the phone, but nothing else happens.
Thanks a lot
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VOICE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EST -5
clock summer-time CA1_DST recurring
voice-card 0
!
!
crypto pki trustpoint TP-self-signed-990320880
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-990320880
revocation-check none
rsakeypair TP-self-signed-990320880
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.18.1 192.168.18.20
!
ip dhcp pool VOICE_SCOPE
network 192.168.18.0 255.255.255.0
default-router 192.168.18.2
option 150 ip 192.168.18.2
dns-server 205.152.144.23 205.152.132.23
!
!
ip name-server 192.168.13.2
!
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711ulaw
h323
emptycapability
sip
registrar server expires max 600 min 60
localhost dns:192.168.18.2
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
voice class h323 1
h225 timeout tcp establish 2
!
!
!
!
!
voice register global
mode cme
source-address 192.168.18.2 port 5060
max-dn 15
max-pool 15
load 7960-7940 P0S3-08-6-00
voicemail 9999
url service http://phone-xml.berbee.com/cgi-bin/weather.pl
tftp-path flash:
create profile sync 000094265841620A
!
voice register dn 1
number 333
call-forward b2bua noan 5001 timeout 5
!
voice register dn 2
number 330
!
voice register dn 3
number 334
!
voice register dn 4
number 331
!
voice register dn 5
number 335
!
voice register dn 6
number 336
!
voice register template 1
dialplan 1
softkeys connected Endcall Hold Trnsfer
!
voice register dialplan 1
type 7940-7960-others
pattern 1 1..........
pattern 2 ....... timeout 2
pattern 3 011.* timeout 2
!
voice register pool 1
id mac 0013.1A6C.3693
type 7940
number 1 dn 1
number 2 dn 3
template 1
dtmf-relay sip-notify
voice-class codec 1
username 333 password cisco
!
voice register pool 2
id mac 000B.5F80.0479
type 7940
number 1 dn 2
number 2 dn 4
template 1
dtmf-relay sip-notify
voice-class codec 1
username 330 password cisco
!
voice register pool 3
id mac 000E.3892.D5D4
type 7940
number 1 dn 5
number 2 dn 6
template 1
dtmf-relay sip-notify
voice-class codec 1
!
!
voice translation-rule 1
rule 1 /.*/ /333/
!
voice translation-rule 3
rule 1 /3../ /5616236333/
!
voice translation-rule 4
rule 1 /\(.......\)/ /561\1/
!
!
voice translation-profile IncomingCalls
translate called 1
!
voice translation-profile PSTN_outgoing
translate calling 4
translate called 3
!
!
!
!
username 5616236333
username username privilege 15 secret 5 $1$W2PC$WHkf.nvnA6SLMAaZsxwSl0
!
!
archive
log config
hidekeys
!
!
!
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
class class-default
fair-queue
!
!
!
!
!
interface Loopback0
ip address 192.168.254.254 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.18.2 255.255.255.0
speed auto
auto qos voip trust
service-policy output AutoQoS-Policy-Trust
!
interface Serial1/0
no ip address
shutdown
!
router rip
version 2
network 192.168.18.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.13.2
!
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
!
!
!
tftp-server flash:/phone/7940-7960/P0S3-08-6-00.loads alias P0S3-08-6-00.loads
tftp-server flash:/phone/7940-7960/P0S3-08-6-00.sb2 alias P0S3-08-6-00.sb2
tftp-server flash:/phone/7940-7960/P003-08-6-00.bin alias P003-08-6-00.bin
tftp-server flash:/phone/7940-7960/P003-08-6-00.sbn alias P003-08-6-00.sbn
tftp-server flash:dialplan.xml
tftp-server flash:RINGLIST.DAT
tftp-server flash:P0S3-08-6-00.loads
tftp-server flash:ringtones/AreYouThere.raw
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.18.3164929 30 absolute rising-threshold 1 33333
falling-threshold 0 owner AutoQoS
!
voice-port 0/0
!
voice-port 0/1
description FAX machine
station-id name FAX
station-id number 5001
!
!
!
sccp local FastEthernet0/0
!
!
!
dial-peer voice 2 voip
description *** 7 Digit Calls for local area 561 ***
translation-profile outgoing PSTN_Outgoing
destination-pattern [2-9]......
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
session transport udp
dtmf-relay rtp-nte
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 3 voip
description *** 11 Digit Calls ***
translation-profile outgoing PSTN_Outgoing
destination-pattern 1[2-9]..[2-9]......
voice-class codec 1
voice-class h323 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
session transport udp
dtmf-relay h245-alphanumeric
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 10 pots
description *** Incoming fax to FXS **
destination-pattern 5001
incoming called-number 5001
port 0/1
!
dial-peer voice 13 voip
description **Incoming Call From SIP Trunk**
translation-profile incoming IncomingCalls
voice-class codec 1
session protocol sipv2
session target sip-server
session transport udp
incoming called-number .%
dtmf-relay rtp-nte
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 911 voip
destination-pattern 911
voice-class codec 1
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
no vad
!
dial-peer voice 8 pots
description ** Outgoing FAX to PSTN **
destination-pattern 5001
incoming called-number 9T
!
gateway
timer receive-rtp 1200
!
!
sip-ua
credentials username 5616236333 password 10175C4E5C40455A5E577D realm 64.154.41.150
authentication username 5616236333 password 7 005D46515D0C5C575D721B
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar dns:sipconnect.ipcomms.net expires 3600
sip-server dns:sipconnect.ipcomms.net
host-registrar
!
!
telephony-service
load 7960-7940 P0S3-08-6-00
max-ephones 24
max-dn 48
ip source-address 192.168.18.2 port 2000
system message Ubuntu
voicemail 9999
max-conferences 4 gain -6
moh music-on-hold.au
web admin system name admin secret 5 $1$PL56$/R0wmXlsAHqmLyeaxAiUp1
dn-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Sep 20 2012 09:44:46
!
!
line con 0
password password
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
ntp clock-period 17180241
ntp server 134.214.100.6
end
VOICE#
11-02-2012 07:38 AM
Humberto,
Does your carrier support T38 transport?
There's no realible means besides T38 to transport faxes over a non-controlled network like the Internet. A single packet loss would cause the T30 session on the analog side to timeout.
11-03-2012 07:16 AM
Thanks for your reply. I have different subnets on my home lab and the CME was very deep inside my network . As soon as I moved CME to the DMZ I started sending and receiving faxes without problem. So, I am asuming that somewere in the middle of the path to the gateway something was not configured to transport the packets properly. SInce my main goal was to send/receive faxes from any subnet, mission accomplished. However, I would like to configure the entire network to be able to send/received faxes from every where within the network to the outside, which I pretend to do it later on. Thanks again.
11-04-2012 07:15 AM
Definetly packet loss or other forms of network disruption could negatively affect a Passthrough FAX transmition.
Good thing is you have been able to start narrowing down the scope of the problem. Perhaps packet captures with SPAN at differnet points will let you identify the source of the problem.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide