cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2866
Views
0
Helpful
5
Replies

Skinny Protocol Versions

andy.carse
Beginner
Beginner

Hi,

Does anyone know how to find what version of the Skinny protocol are used in the different firmwares on 79XX handsets.

Rgds Andy

1 ACCEPTED SOLUTION

Accepted Solutions

Brett Fritzsch
Cisco Employee
Cisco Employee

Andy,

This is the best I could find internally:


SCCP Version Third-Gen Phone Load
5.0 v8 8.0.1
5.1 v8 8.2.1
6.0 v12 8.3.1
6.1.1 v12 8.3.x (new phone load not required)
6.1.2 v15 8.3.4
7.0 v17 8.4.1
8.0 V19 9.0.2
8.5 V20 9.1.1

Note that the phone load is the first build that had the features for  the CCM, it's not the only firmware that works or ships with the CCM

Hope this helps!

-Brett

View solution in original post

5 REPLIES 5

Brett Fritzsch
Cisco Employee
Cisco Employee

Andy,

This is the best I could find internally:


SCCP Version Third-Gen Phone Load
5.0 v8 8.0.1
5.1 v8 8.2.1
6.0 v12 8.3.1
6.1.1 v12 8.3.x (new phone load not required)
6.1.2 v15 8.3.4
7.0 v17 8.4.1
8.0 V19 9.0.2
8.5 V20 9.1.1

Note that the phone load is the first build that had the features for  the CCM, it's not the only firmware that works or ships with the CCM

Hope this helps!

-Brett

Thanks Brett,

This is exactly what I was after, it confirms what wireshark states about why Skinny after V18 doesn't get decoded properly.

Rgds Andy

Brett, can you update this information for CUCM v8.6 and v9.x ?

Thanks in advance!

Best Regards.

Marcio,

Just to chip in here. The latest sccp version I am aware of is v20. That means that pho ne loads from 9.X are running v20. The cucm version doesnt matter. What is key is the firmware on your phones. You could have a cucm 7.X with phones running firmware 9.X and consequently they will be on SCCP v 20

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

I am missing the Cisco wireless phones (7921, 7925). Hope Brett or any one else can confirm it here in that thread which versions they are stucked into.

From packet capture analysis they have no version identifiable. But it is for sure below SCCP version 20 since Early Offer is not working without MTP. Required SCCP capability messages are described in the new and change notes of UCM 8.5.1 (http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/rel_notes/8_5_1/delta/delta.html)

There was a note from another user that SCCP version 20 started with Firmware Phone Load 9.2.2. I verified it only with the most recent firmware 9.4.2. Since Skinny specifications are not public there is no clean implementation for wireshark available.

 

BR,

Christoph

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: