cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1723
Views
8
Helpful
17
Replies

The selected file is not valid.please ensure that cop\ISO is intended

iptsupport
Level 4
Level 4

Hello ,

Following Bug CSCwd64245

I Try to Install  in CUCM patch : ciscocm.v1_java_deserial-CSCwd64245.cop.sha512

But I got error :"The selected file is not valid.please ensure that cop\ISO is
intended for this release "

My version is 12.5.1.12900

any idea?

1 Accepted Solution

Accepted Solutions

Hi,

Please also make sure you have installed this on your cucm ciscocm.enable-sha512sum-2021-signing-key-v1.0.cop.sgn.

https://software.cisco.com/download/home/286322286/type/286319173/release/COP-Files

This woud enable the installation on Sha 512 encrypted files

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

View solution in original post

17 Replies 17

Per the bug note your version of CM is not affected by this defect.

Known Affected Release
12.0(1.10000.10) 12.5(1.10000.22) 14.0(1.10000.20)

 



Response Signature


Roger,

The cop file's Readme states:
This COP file, ciscocm.v1_java_deserialCSCwd64245.cop.sha512 is only designed for the following products and versions:
Any 12.5(1) release lower than 12.5.1.18900-40
Any 14 release lower than 14.0.1.13900-155

I also had a TAC engineer guide me to this cop file for my servers running 12.5(1)SU4. Do you have different information?

 

Hi,

If  you used the web Gui to install that patch it would fail. It should be installed through CLI

Can you please post the output of a show version active?

 

Please let us know

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"

No I don’t, I referred to the information in the bug note. If the readme has other information than that it’s not very good as it would cause much confusion, just as in your case. I would recommend you to use the option to post feedback on the bug note and state that the list of affected versions are incorrect/incomplete. I just did that, but if there are more feedbacks on this it has a bigger impact.

That said I would go on the information in the readme file. As @Carlo Poggiarelli wrote can you please share the output for show version active so that we can verify that you have installed any pre-requisite file(s). Especially the COP file for the signature update from 2021 is crucial to be able to install any new installation as pretty much any update released now requires this.



Response Signature


This bug affects all CUCM 12.5 versions before SU8 as well as all CUCM 14 versions before SU3
https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cucm-rce-bWNzQcUm

Gerry

 

 

honekr
Level 1
Level 1

Hello,

my CUCM version is 12.5.1.13900-152 and I have the same problem.

Based on the bug note that version is not affected by the defect either.

Known Affected Release
12.0(1.10000.10) 12.5(1.10000.22) 14.0(1.10000.20)

 



Response Signature


Hello Roger,

Thanks for your information. I have random answers with different TACs; One of the TAC engineer says my version is affected and 2nd says no.  I have following CUCM version. Do you think this is impacted?

System version: 12.5.1.16900-48

Also do we need to restart CUCM node and phone while installing this cop? 

 

Based on the readme for the COP file that version would be affected. See the OPs response to me. What is required after the install would be stated in the readme file.



Response Signature


This is what is stated in the readme file for the effect at installation.

image.png



Response Signature


The GUI correction has been used and the patch update cannot be stopped. Is there a way to solve it?

 

 

As the installation fails on the first attempt, due to that you did it from the webUI even if it is clearly stated in the readme that you should not use that to do the installation, you’ll need to cancel the installation before you try to run it again on a second attempt from CLI. You do this with the utils system upgrade cancel command.



Response Signature


Hi,

The affected release is 12.5(1) 

 

UCSInstall_UCOS_12.5.1.10000-22.sgn.iso

Please rate all helpful posts "The more you help the more you learn"