Showing results for 
Search instead for 
Did you mean: 

Xlite connect to CME behind NAT

Level 1
Level 1


When Xlite is in the same network with CME the registration works fine. When I try to connect Xlite outside the network I receive 408 - Request Timeout. The CME is behind NAT so I configure port forward - public 5060 to CME 5060 port, but the same result. With the same port forward configurations and non-Cisco gateway the registration works fine.

Are there any other configurations for CME in order to register Xlite from outside the network?


2 Replies 2

Dennis Mink
VIP Alumni
VIP Alumni

please provide us with the make and model of you FW as well as config.   did you run wireshark at all on your xlite machine?   what sort of other diagnostics have you performed?

Please remember to rate useful posts, by clicking on the stars below.

i have the same issue except i didn't try with non-cisco gateway

my CME is behind NAT and i need to register x-lite on it from outside network, i have no problem when i tried to register from inside

here is my config


voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip


registrar server expires max 1200 min 300

voice register global

mode cme

source-address port 5060

max-dn 2

max-pool 2

authenticate register

tftp-path flash:

create profile   

voice register dn  1

number 1001

allow watch


voice register pool  1

id mac 0000.0000.1001

number 1 dn 1

username 1001 password cisco

codec g711ulaw