cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

254
Views
5
Helpful
4
Replies
Highlighted

OSPF Routing Protocol Not working

Hi Everyone, 

 

I am trying to ping from PC10 to PC-class1-internet but i am unable to do so . 

 

I have configured OSPF protocol on both the routers (R1 & R2) and all on the interfaces but still cant. 

THe network topology is attached for your information. 

Please need your help ASAP.

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Re: OSPF Routing Protocol Not working

Hi @ZAINALATTAS9656 ,

 

You have to make some changes to your settings:

 

Your serial links have the same network, so you must assign a different network to the link between Router1 and Router2.

You have some configurations that do not correspond in the link between the routers.

In short, your interfaces should look like this:

 

Router1

interface Serial0/3/1

bandwidth 64

no ip address

ipv6 address FE80::1 link-local

ipv6 address 2001:AD3:ABCD:8::1/64

ipv6 ospf 1 area 0

clock rate 64000

!

 

Router2

interface Serial0/3/0

bandwidth 64

no ip address

ipv6 address FE80::1 link-local

ipv6 address 2001:AD3:ABCD:8::2/64

ipv6 ospf 1 area 0

 

After those changes, the ping is successful:

Captura de Pantalla 2019-09-22 a la(s) 14.33.16.png

 

I attached the file with the changes

 

Regards

 

 

 

4 REPLIES 4
Beginner

Re: OSPF Routing Protocol Not working

Hello ZAINALATTAS9656,

Your PCs connected to switches "Class_tutors" and "Switch_Class2" don't even have IPv6 assigned, only the Link Local Addresses. I'm not an expert in IPv6 but I'm pretty sure you need to use Unicast Addressing on all your PCs just as you did on PCs connected to switch "Center_Admins".

That's probably why you don't have any communication between those two rooms.

I hope this has been helpful.

-Ricardo S.N., Regards!

Re: OSPF Routing Protocol Not working

i am using ipv6 only i did not use ipv4

Re: OSPF Routing Protocol Not working

I am using ipv6 only I did not use ipv4

 
 
Advocate

Re: OSPF Routing Protocol Not working

Hi @ZAINALATTAS9656 ,

 

You have to make some changes to your settings:

 

Your serial links have the same network, so you must assign a different network to the link between Router1 and Router2.

You have some configurations that do not correspond in the link between the routers.

In short, your interfaces should look like this:

 

Router1

interface Serial0/3/1

bandwidth 64

no ip address

ipv6 address FE80::1 link-local

ipv6 address 2001:AD3:ABCD:8::1/64

ipv6 ospf 1 area 0

clock rate 64000

!

 

Router2

interface Serial0/3/0

bandwidth 64

no ip address

ipv6 address FE80::1 link-local

ipv6 address 2001:AD3:ABCD:8::2/64

ipv6 ospf 1 area 0

 

After those changes, the ping is successful:

Captura de Pantalla 2019-09-22 a la(s) 14.33.16.png

 

I attached the file with the changes

 

Regards

 

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards