ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
866
Views
0
Helpful
1
Replies
Highlighted
Beginner

l2vpn not coming up with segment routing

I have following topology

R1----------R2----------R3

R1 is ASR 9000 series router and R3 is ASR 900 router. Both are enabled with segment routing. I created one l2vpn xconnect from R1 to R3 which is not coming up.

Below is the configuration of both the routers

R1# 

router ospf 1
router-id 5.5.5.5
segment-routing sr-prefer
segment-routing prefix-sid-map advertise-local
area 0
segment-routing forwarding mpls
mpls traffic-eng
segment-routing mpls
interface Loopback0
prefix-sid index 3
!
interface TenGigE0/0/2/0
cost 1
network point-to-point
passive disable
fast-reroute per-prefix
fast-reroute per-prefix ti-lfa enable
!
interface TenGigE0/0/2/2
cost 1
network point-to-point
passive disable
fast-reroute per-prefix
!
!
mpls traffic-eng router-id Loopback0
!

l2vpn
pw-class MPLS
encapsulation mpls
ipv4 source 5.5.5.5
!
!

xconnect group SR-P2P-1
p2p SR-P2P-1
interface Bundle-Ether100.181
neighbor ipv4 3.3.3.3 pw-id 181
pw-class MPLS
!
!
!

R3#

router ospf 1
router-id 3.3.3.3
segment-routing area 0 mpls
segment-routing mpls
segment-routing prefix-sid-map advertise-local
network 3.3.3.3 0.0.0.0 area 0
network 10.10.10.8 0.0.0.1 area 0
network 192.168.12.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

segment-routing mpls
!
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family
!
!
connected-prefix-sid-map
address-family ipv4
3.3.3.3/32 index 1 range 1
exit-address-family
!
!

interface Port-channel22

service instance 181 ethernet
encapsulation dot1q 181
xconnect 5.5.5.5 181 encapsulation mpls
!

Both routers are configured with segment routing only

R1# sh l2vpn xconnect detail

Group SR-P2P-1, XC SR-P2P-1, state is down; Interworking none
AC: Bundle-Ether100.181, state is up
Type VLAN; Num Ranges: 1
VLAN ranges: [181, 181]
MTU 9188; XC ID 0xa0000005; interworking none
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0
drops: illegal VLAN 0, illegal length 0
PW: neighbor 3.3.3.3, PW ID 181, state is down ( local ready )
PW class MPLS, XC ID 0xc0000008
Encapsulation MPLS, protocol LDP
Source address 5.5.5.5
PW type Ethernet, control word disabled, interworking none
PW backup disable delay 0 sec
Sequencing not set

PW Status TLV in use
MPLS Local Remote
------------ ------------------------------ -----------------------------
Label 24042 unknown
Group ID 0x1e0 unknown
Interface Bundle-Ether100.181 unknown
MTU 9188 unknown
Control word disabled unknown
PW type Ethernet unknown
VCCV CV type 0x2 0x0
(none)
(LSP ping verification)
VCCV CC type 0x6 0x0
(none)
(router alert label)
(TTL expiry)
------------ ------------------------------ -----------------------------
Outgoing Status (PW Status TLV):
Status code: 0x0 (Up) in Notification message
MIB cpwVcIndex: 3221225480
Create time: 19/06/2017 14:24:55 (20:48:10 ago)
Last time status changed: 19/06/2017 14:31:42 (20:41:24 ago)
Error: MTU mismatched
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0

Can anyone help me if I am missing something.

1 REPLY 1
Highlighted

I see that there is an MTU

I see that there is an MTU mismatch between the two PE routers. Fix that and see if that does it... 

Outgoing Status (PW Status TLV):
Status code: 0x0 (Up) in Notification message
MIB cpwVcIndex: 3221225480
Create time: 19/06/2017 14:24:55 (20:48:10 ago)
Last time status changed: 19/06/2017 14:31:42 (20:41:24 ago)
Error: MTU mismatched

Content for Community-Ad

This widget could not be displayed.